56

Yesterday I updated my Thinkpad T530 from Ubuntu 13.10 to 14.04 (both x64). Since then the integrated webcam is not working anymore. I tried to use it with Skype and Google Hangouts, but it says that no video device is found. I found some solutions but they did not work. First thing I did was to check if the integrated webcam is activated in bios settings. Then I found this "How can I get my webcam to work with Ubuntu 14.04?" but I don't have any /dev/video* device.

Can anybody tell me what to do? Thanks.

6
  • 8
    Have you tried activating it using the function [Fn] keys on the laptop? – chesedo May 6 '14 at 9:41
  • 1
    Yes, but it did not work. – user278520 May 6 '14 at 9:47
  • 8
    Try sudo modprobe -r uvcvideo && sudo modprobe uvcvideo – user.dz Jun 14 '14 at 13:46
  • 1
    Can you please provide the results of lsusb – Evenbit GmbH Jun 18 '14 at 18:12
  • 2
    user.dz, your solution didn't work for me – The_Martian Jun 16 '17 at 23:00

11 Answers 11

71

I know that a long time passed since you posted.

with lspci get:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

The solution was to activate the webcam with the keys: fn + CAM in my case f10.

I hope this helps. Regards.

8
  • 27
    fn + CAM (f10) also worked for my integrated web cam. – quux00 Aug 29 '15 at 14:12
  • 5
    Kind of embarrassingly simple, but that worked for me, too. – pattivacek Oct 5 '16 at 2:31
  • 3
    Wtf just happened. That worked! LOL – Lucas Teske Sep 17 '17 at 23:11
  • 2
    Uff, that was simple – Malik Mudassar Dec 21 '17 at 12:26
  • 1
    Note: after you press the camera button (e.g. fn + F10) , you may need to restart the application in order for the application to recognize the webcam. This was the case with cheese for me. – cmo Oct 25 '18 at 3:28
35

I finally figured this out. For the longest time, I just thought the web camera in my laptop was broken. It didn't even show up when doing an lsusb ...and it won't, because hitting the web camera function key on the laptop adds/removes the device in hardware as if it has been physically connected/disconnected.

You must hit Fn+<Camera Key> on your keyboard and then you'll see the following in your kernel logs:

[22219.057985] msi_wmi: Unknown event received [22219.509572] usb 3-1.4: new high-speed USB device number 6 using ehci-pci [22219.646222] usb 3-1.4: New USB device found, idVendor=5986, idProduct=055c [22219.646229] usb 3-1.4: New USB device strings: Mfr=3, Product=1, SerialNumber=2 [22219.646233] usb 3-1.4: Product: BisonCam, NB Pro [22219.646237] usb 3-1.4: Manufacturer: Generic [22219.646239] usb 3-1.4: SerialNumber: 200901010001 [22219.649336] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:055c) [22219.652486] input: BisonCam, NB Pro as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.4/3-1.4:1.0/input/input19

Here is what the key looks like on my MSI WS-60. It varies from laptop to laptop. Hit it and you should watch /dev/video0 appear and disappear.

Photo of an MSI WS-60 Keyboard's Web Camera Function Key

7
  • 2
    Thanks! I also have an MSI laptop. Looking at that icon now, I can see how it sorta looks like a camera. But before this, I thought it was something to do with a monitor. They need a better icon! – Delorean Jun 28 '17 at 5:07
  • 2
    what the actual f***. why does this button exist!? thanks for the fix, saved me! – lollercoaster Jul 20 '17 at 18:21
  • 2
    Hahaha, have the same keyboard you do. Thanks for that. Had no idea what that button actually was ;) – TheSHEEEP Nov 10 '17 at 15:34
  • 1
    Can't thank you enough! how sneaky. I must have hit this key combination by accident at some point without noticing it (and if I had noticed it I wouldn't have known what it was for ;-) – Silvio Levy Apr 3 '18 at 7:18
  • The issue was frustrating, but the fact that the switch is at the hardware rather than the software level is an excellent security feature – Maxim Apr 24 '20 at 8:16
13

Install webcam driver packages and needed software

sudo apt-get install cheese build-essential linux-headers-`uname -r`
6
  • You are awesome! thanks for the command. I just used it and my Skype video back to normal functionality. – Hesam Sep 29 '15 at 20:59
  • run above command but not working for ubuntu 16.04 :( – amit_game Jan 14 '17 at 5:46
  • works for me for Ubuntu 16.04 – JDiMatteo Oct 18 '17 at 17:15
  • 1
    apt-get install cheese was sufficient on my ancient HP notebook running 16.04, after that all applications could find the webcam. – Tezi Konj Dec 26 '17 at 16:04
  • worked in ubuntu 18.04 / lenovo laptop as well. Thanks ! – ankit.vishen Mar 2 '19 at 17:52
7

For proud owners of the Asus Zenbook!

My camera did not work after upgrading to Ubuntu 18.04. So I ran sudo apt-get install guvcview and restarted my computer. And it works now! Refer to this guide for further questions:

https://help.ubuntu.com/community/AsusZenbook#Webcam

2
  • 1
    also worked for my System76 machine after upgrading to 18.04 =) – Michael Schock Feb 17 '19 at 2:24
  • 1
    sudo apt-get install guvcview, followed by modprobe uvcvideo (which may not have been necessary), followed by reboot, followed by Func+F6, followed by cheese worked for me on Ubuntu 18.04 LTS. Func+F6 now toggles access to built-in webcam on/off. What I still don't understand: Why installing guvcview was needed now when the webcam worked without it for approx 5-1/2 of the 6 years I've had this machine. – James E Keenan Dec 20 '19 at 14:38
3

The comment by user.dz on the original question provided the solution worked for me:

sudo modprobe -r uvcvideo && sudo modprobe uvcvideo
2

You can try GTK UVC video viewer . This software is available in software center. Then go to Videos and select the device. I have two device connected with my computer. I keep my mobile device active, because of that in device it is showing Symphony FT45. In your case chose the default device. This might solve your problem. Have fun.

enter image description here.

2

I had a similar problem - it will probably be solved when you update and upgrade your computer.

try this command:

lsmod            

In this screen you'll find the devicename, its number, the third column means that your device activated or not (0 means not activated). See screenshot below:

enter image description here

To activate this device use this command :

modprobe <name of the device>

your kernel will run the activate automatically after rebooting.

You can also do it manually through this file /etc/rc.d/rc.modules

5
  • 32
    which one is the webcam?? – Xi'an Feb 24 '15 at 16:08
  • 4
    I suppose uvcvideo is camera and it's not working for me. It's still showing 0. – aroma Aug 12 '18 at 11:02
  • /etc/rc.d/rc.modules works! – Brain90 Jan 7 '20 at 12:47
  • I have two laptops where it says 0 for uvcvideo, but the camera on video works on one but not the other. – toonarmycaptain Aug 24 '20 at 13:42
  • This answer is so stupid now I become Forrest Gump. What the heck. – GeneCode Dec 5 '20 at 5:52
2

In my case (Lenovo Ideapad Y500, elementaryOS) installing the following packages solved the problem:

sudo apt-get install libsbigudrv2 libsbigudrv0
1

If you change your display manager on Mint from mdm, to lightdm your sound and video won't work. I tried everything on any website but nothing worked. I just reverted back to mdm from lightdm and sound-video-webcam was back and running fine.

0

I also ran into an issue where the integrated webcam was not detected (no /dev/video*), with similar symptoms to the 'disable camera button' responses above. My work laptop does not have that button, but there is a BIOS setting to enable the camera, which was off.

I restarted and entered Bios Setup (F12) and for me the setting was under:
System Configuration > Miscellaneous Devices > Enable Camera

I didn't know this option even existed, hopefully this post saves someone some time.

0

Look for a physical switch somewhere on your laptop if there is no key combination or BIOS setting to kill the camera. On my machine, HP Spectre x360 Convertible 15-df1xxx, this was a tiny, miniature, unnoticeable switch right next to the USB port. Seems I had accidentally bumped into it while upgrading the Ubuntu version using a USB stick. Seeing no key combo or BIOS option and finding no software fix, I was pretty convinced this was caused by the kernel upgrade. Double check your hardware before you file a bug report; you might get surprised!

Not the answer you're looking for? Browse other questions tagged or ask your own question.