3

I am unable to update my ubuntu server 14.04 using apt-get update.

Outcome is:

W: failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/trusty/inrelease 

And another error is:

/usr/local/snort/bin/snort: error while loading shared libraries: libdnet.1 : cannot open shared object

How can I solve this?

0

I just had this same issue. My company has a firewall that stopped apt-get from getting to the http sources. They still allow ftp traffic, so I was able to work around the firewall by changing all the "http" sites in sources.list to "ftp". For example, in file /etc/apt/sources.list, I changed line:

deb http://us.archive.ubuntu.com/ubuntu/ trusty-security main

to

deb ftp://us.archive.ubuntu.com/ubuntu/ trusty-security main

Now apt-get is able to fetch the files from the repositories.

0

edit /etc/resolve.conf file and change nameserver adress e.g 8.8.8.8 if thats not solving your problem try this tutorial

  • Some ISP disallow the usage of google's nameserver 8.8.8.8 which might be you in further trouble. Keep that in mind. – Karl Richter Jun 20 '15 at 11:22
-2

You should try sudo apt-get upgrade that will run as superuser and upgrade you to 16.04 if you dont want that try sudo apt-get update to run the command as superuser thats what u usually do if your updating your current version there also could be no new updated versions but I bet there are if you want to check you can use sudo apt-get dist-upgrade to upgrade your current verison of ubuntu like 14.04 to 14.14 for expmple though ther might not be a 14.14 version of ubuntu!!! Thank you for the question!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.