2

When I am trying to create and open a new odt/doc document (by creating a file called xyz.odt), strange characters are showing up. The document should be empty ideally when its opening.

When I delete the chars and write something to save the file, the file is fine, i.e. the data is retained correctly and no strange chars are shown.

These are the characters I see:


��#ࡱ#�################;###�� #############################����####����########�������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������R#o#o#t# #E#n#t#r#y#################################################������������####################################����############################################################################������������####################################����############################################################################������������####################################����############################################################################������������####################################����########

  • 1
    What do you use to create new LO documents? Do you create them from the file manager or from inside the application? – Glutanimate May 6 '14 at 9:45
2

This looks like a corrupt default template.

If you're creating them from the file manager (nautilus or whatever replacement you use), then check the templates in ~/Templates.

If you're creating them from within LibreOffice itself (through File > New) then try creating a fresh document (i.e. remove all the mojibake you have there) and then save your new blank file as a template and set it to be the new default, as per https://help.libreoffice.org/Writer/Changing_the_Default_Template

Edit — Updating from new information in comment:

If you create a new "Empty Document" through nautilus, it will create a single-byte file with whatever name you give it. Some file formats can work well with a zero-byte file, in particular text files (still the most common form of file in Linux).

LibreOffice does not. It will do a valiant job at trying to interpret that nothingness as a valid writer file, but the result will be pretty much as it is in the question.

To create LibreOffice files directly from nautilus or another file manager, you need to tell that file manager what a "new" LibreOffice file looks like.

  1. Open LibreOffice, and start a new document.
  2. (Optional) Edit the fonts, etc. to be how you must often like them to be when you start a new document.
  3. Save it in ~/Templates (that is, the Templates directory in your home directory) called something like "New LibreOffice Writer Document".

Now when you right click in Nautilus you have the added option New > Document > New LibreOffice Writer Document.

You can also customise further. E.g. you can set it up to offer choices of "New Plain LibreOffice Writer Document", "New Letter", "New Manuscript Format Document", "New [your business name] Document" (with letterhead, etc.) or whatever types of documents you yourself most often create.

  • Hi Jon. If I am creating within Libre Office, then its fine. But I usually create as I have mentioned: I create Rt Click on folder> New Document>Empty Document to create a new file and call it xyz.odt. I tried the template thing. No use. Also I have checked my Nautilus. Theres no action defined. Am I missing or overlooking something too obvious? – Aybid May 7 '14 at 12:23
  • Ah. You are creating a zero byte document, naming it as a libreoffice document, and then opening it as such. Add a new blank libreoffice document to your Templates directory and it should add another option as well as "empty document" (may need a nautilus restart, though probably not). – Jon Hanna May 7 '14 at 12:41
  • This also let's you add a few different starting documents to the menu. E.g. a plain one, a letter headed one, one in manuscript format, etc. – Jon Hanna May 7 '14 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.