0

I am running Ubuntu 14.04 and had not had problems with the wifi until a couple of days ago. I have tried numerous help posts, most of which with similar fixes, and nothing worked.

It started after I switched to using 'Auto ethernet' in order to download things faster, and when I tried switching back to wireless, I found that the hardware switch for the wireless has been disabled, and I can no longer connect wirelessly.

Hitting the actual switch doesn't do anything.

sudo rfkill list all returns:

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

lspci | grep Wireless returns:

10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

sudo rfkill unblock all does nothing and neither does: sudo rfkill unblock wlan

Nothing in the hardware changed, I only noticed the problem after I installed another distribution on another partition, when I unplugged it from the ethernet.

3
  • it would help to know what kind of laptop you have – mchid Aug 8 '14 at 2:17
  • also askubuntu.com/questions/380586/… – mchid Aug 8 '14 at 2:33
  • If you are dual-booting with another distribution which hardblocked your wifi, then probably that distribution can unblock it too. On my laptop, if I disable wifi in Windows I'm not able to unblock it in Ubuntu. Ubuntu soft blocks the wifi on my system and doesn't seem to have control over the hard block switch while Windows seems to have. – To Do Aug 8 '14 at 4:46
0

Hard blocked means your wifi switch or your wifi fn key on your laptop is switched. Press the wifi key or press fn and the wifikey at the same time to toggle hard blocked on and off. Rfkill does not have power over the fn key or the physical switch.

Also, check this setting "enable WIFI" in Network Manager is selected as well because it will also return the "hard blocked" disposition. enter image description here


Also, check your BIOS settings.

How to unblock something listed in rfkill?


an answer by vbachev

  1. dual-boot to windows where the button works
  2. enable wifi
  3. reboot to linux

How to unblock something listed in rfkill?


APPLICATIONS MENU > SYSTEM TOOLS > PREFERENCES > SYSTEM SETTINGS

open NETWORKS

Now, toggle the AIRPLANE mode off and while it is still open (leave it alone) press your standby/power button. Let the system go into standby. Next resume the system and toggle your wifi button. https://forums.kali.org/showthread.php?368-ifconfig-wlan0-up-%93SIOCSIFFLAGS-Operation-not-possible-due-to-RF-kill%94


Remove the battery and the ac adapter. Press the power button to purge the system. Replace the battery and ac adapter and power back up.https://forums.kali.org/showthread.php?368-ifconfig-wlan0-up-%93SIOCSIFFLAGS-Operation-not-possible-due-to-RF-kill%94

4
  • Not all laptops use function keys for WiFi switches – ElefantPhace Aug 8 '14 at 1:29
  • @ElefantPhace It sounds like you have something to add but aren't willing to share the knowledge – mchid Aug 8 '14 at 2:10
  • 1
    No just that not all laptops use the function keys to enable/disable WiFi. For example my current viao has a physical switch. Also what if user was using a desktop with a wireless card or dongle? – ElefantPhace Aug 8 '14 at 2:13
  • @ElefantPhace right on, thanks! I've updated the answer. If using a USB device or similar it would be listed under lsusb instead of lspci. As far as I know the last half of my answer applies to "hard blocked" USB – mchid Aug 8 '14 at 2:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.