In an attempt to fix some minor issues with the splash screen, I ran this script: http://www.webupd8.org/2010/10/script-to-fix-ubuntu-plymouth-for.html

Big mistake. My resolution is now stuck at 1024x768 (the screen is 1280x900). I can't change it through the Monitors settings, and either there's lots of old guides out there or my Xorg config doesn't exist. I tried running the cleanup version of the "fix script" but nothing changed. Oh and the graphics settings are also at minimum all of a sudden.

I also tried all sorts of dpkg --reconfigures, no luck there either.

alexander@natty:~$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       61.0* 
   800x600        61.0 
  • graphics card? Are you running with any additional Graphics Drivers? Please supply your current xorg.conf. Please supply your current grub boot line. – fossfreedom May 31 '11 at 6:55

What this script does:

  1. In /etc/default/grub

    1. replace

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"


      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option='$resolution',mtrr=3,scroll=ywrap"

    2. set GRUB_GFXMODE=$resolution
  2. In /etc/initramfs-tools/modules
    1. add uvesafb mode_option=$resolution mtrr=3 scroll=ywrap
  3. In /etc/initramfs-tools/conf.d/splash
    1. add FRAMEBUFFER=y

Reverse whatever it actually did do, and do this:

 sudo update-grub2
 sudo update-initramfs -u
| improve this answer | |
  • Thanks very much! I had done everything except removing GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option='$resolution',mtrr=3,scroll=ywrap", and changing that fixed it. – Vallery May 31 '11 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.