This question already has an answer here:

I'm a newbie on Linux stuff and maybe the solution to my problem is obvious, but I need your help.

I decided to install Kubuntu 14.04 on my laptop (HP pavilion g6-2330sf) and the installation worked perfectly, but even if my Ethernet connection works, the wireless network refuses to be enabled.

So I spent a couple of hours trying to install drivers, NetworkManager etc... but nothing works, or should I say I can't make it work.

When typing the following command in the console $ sudo lshw -C network I get the following output:

    description: Ethernet interface
    product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:06:00.0
    logical name: eth0
    version: 05
    serial: 74:46:a0:85:dd:93
    size: 100Mbits/s
    capacity: 100Mbits/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip=************** (knowingly hidden) latency=0 link=yes multicast=yes port=MII speed=100Mbits/s
    resources: irq:46 ioport:2000(size=256) memory:f0204000_f0204fff memory:f0200000-f0203fff

*-network UNCLAIMED
    description: Network controller
    product: AR9485 Wireless Network Adapter
    vendor: Qualcomm Atheros
    physical id: 0
    bus info: pci@0000:07:00.0
    version: 01
    width:64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: latency=0
    resources: memory: f0100000-f017ffff memory:f0500000-f050ffff

Furthermore when using the command nmcli nm I get the following output:

RUNNING               STATE                 WIFI-HARDWARE   WIFI        WWAN-HARDWARE   WWAN
running               connected             enabled         disabled    enabled         disabled

I already read the following Questions:
Wireless networking not working after resume in Ubuntu 14.04

How do I get an Atheros AR9485 wireless card working?

Qualcomm Atheros AR9485 Wireless Network Adapter not working on Ubuntu 13.10

Could someone help me activate the Wireless network?

marked as duplicate by Fabby, David Foerster, karel, jokerdino Jan 20 '17 at 15:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Many thanks it worked for me on Samsung Ativ i5 kubuntu-14.04 Network becomes active on resuming from sleep. Choosing the recommended graphic driver (NVIDIA) disabliing the Nouveau driver did the trick. Can this question be marked SOLVED? ddave – user305095 Jul 13 '14 at 10:12

I had a similar problem with my DELL E5420, I have fixed it by disabling the default driver. Go to system settings, Driver Manager, and unmark the marked driver. Then reboot the computer with the wireless turned on. After reboot, wait a while, then turn off wireless and turn on it again. After, try con connect to some network.

I hope this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.