0

Im trying to unrar a file to the folder /media/ EDIT: OK, the actual folder is '/mnt/sdb1/BitTorrent/readyforplex/' not '/media/'. when I run the unrar command I get an error that says "Cannot create... permission denied", but it does create the correctly named file with a file size of 0. If I chmod 777 that file and re-run the unrar command it unrar's everything just fine. If I delete everything, chmod 777 the folder and run the unrar command, I get the original error. I could really use some help here.

  • It seems to me that /media/ is a system directory which stores mounted devices. Is there a reason you are trying to extract a file into there? – Christopher Kyle Horton May 5 '14 at 22:37
  • /media/ was just an example folder, I didn't think that was an important detail. – user218314 May 5 '14 at 22:39
  • Please, post exact steps and commands you follow to mount, change permissions and unrar. – Akronix May 6 '14 at 18:30
1

/media is owned by root and it can be modified only with superuser privileges. That means that, if you want to unrar, create or copy any file to that directory, you have to precede the command by sudo or launch the program you are going to work with, launched with gksu.

  • My fault. the actual folder is /mnt/sdb1/bittorrent/readyforplex/ and the permissions is set to 777, and I still get the error. – user218314 May 5 '14 at 22:44
  • the permissions to which directory? have you tried to execute it with sudo? – Akronix May 5 '14 at 23:01
  • @user218314 are you sure that the it is not mounted in read-only mode? how did you mount it? – Akronix May 5 '14 at 23:07
  • i used the the command "sudo chmod -R 777 /mnt/sdb1/bittorrent/readyforplex/" and yes, running unrar with sudo does work, but this is going to happen automatically within qbittorrent so that's not an option. – user218314 May 5 '14 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.