0

I am trying to install MATLAB R2014a on Ubuntu 14.04 LTS. I download the .iso file (from my University) and mount it using Disk Image Mounter. Then I open a terminal, switch to the directory where the image is mounted, and enter this command:

sudo ./install

Then it runs a bunch of lines that all say cp: failed to extend 'some stuff' or cp: error reading 'somestuff' and then Input/output error. What am I doing wrong?

Thanks for any help.

  • are you sure the matlab version is correct? it might be the win version you are trying to install. – daemonoid May 12 '14 at 7:00
  • You can use GNU octave. – Dusan Milosevic May 15 '14 at 11:45
1

Yes, I just installed Matlab 2014a from .iso file on Ubuntu 14.04, both 64 bits.

I see there are still issues regarding mounting and installation procedures. My simple experience was just downloading the iso file and extract it there (not mount).

Then chmod +x ./install replied permission denied. This needed making the java file in /matlab-extracted-folder/sys/java/jre/glnxa64/jre/bin/ executable using chmod +x ./java.

Now come back to the matlab extracted folder and install as sudo ./install.

0

Answer by Sudheer is not correct. Matlab 2014a is available for several Linux distributions, including some Ubuntu versions, however Mathworks does not give any promises about Ubuntu 14.04, but I doubt your problem is the Ubuntu version, unless you are trying to install 64bit Matlab on 32bit Ubuntu. See the link:

http://www.mathworks.se/support/sysreq/current_release/index.html?sec=linux

I suggest you start troubleshooting from: https://help.ubuntu.com/community/MATLAB

I know it is about Matlab 2012a, not 2014a, but these instructions worked fine with my Ubuntu 12.04 and Matlab 2013b.

0

Just in case for a new user who is coming here read this answer that's what worked for me: Matlab install - Java permission denied

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.