2

I have tried to disable the firewall and allow the port 123 as explained in other questions, but it didnt help me,

it keeps telling me

 $ sudo ntpdate -u pool.ntp.org 
 5 May 05:41:40 ntpdate[3614]: no server suitable for synchronization found
2

In light of the ntp DDOS attacks many ISPs took the heavy handed approach and blocked all ntp traffic. Usually this means that they have an ntp server inside of their network for customers to use. I would check with your ISP to see if they have an ntp server to use and/or if they are blocking ntp.

In the mean time just to double check that you did not somehow get screwy results:

  1. Check to make sure that your DNS is working:

    $ host pool.ntp.org

  2. Check to make sure that you did not get four screwy servers. This command will try 16 pool servers. If this does not work your ISP is definitely blocking ntp (assuming you did turn off all FW rules)

    $ seq 0 3 |xargs --replace ntpdate -p 1 -d {}.pool.ntp.org |grep receive

    If a server responds you will see something like: receive(xxx.xxx.xxx.xxx) where xx.xx.xx.xx is the IP address of the ntp server that responded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.