I've installed the latest ubuntu release (10.4) on my HP mini 110, the installation went smoothly but I don't have any wireless connection. (it says wireless disabled)

I installed ubuntu side by side with an already existing windows XP, on windows wireless works fine.

I tried both ubuntu desktop edition and netbook remix, but same problem on these two modes.

It happens both when I run ubuntu from the USB and when it's installed on the hard-drive.

I found many articles about the broadcom network card issues this netbook has, but they all suggest to run:

sudo apt-get update
sudo apt-get --reinstall install bcmwl-kernel-source
sudo reboot

(e.g. this official guide)

however this doesn't seem to solve my problem.

  • Hi, I believe I am running into the same issue with my HP Mini. However, was your mini able to recognize a wired connection? Mine is failing to enable lan|wlan firmware altogether. Also, could you mark which answer worked for you? – mfg Nov 1 '10 at 13:01
  • Did any of the solutions below work for you? – mfg Apr 23 '11 at 1:14

Let me mention the simple answer that you have probably tried for future seekers. This has worked for me on my last two installs involving broadcom wireless drivers. It does however require a wired connection.

Start up System > Administration > Hardware Drivers
Let it build the database, then see if there is a Broadcom driver available that just needs to be "activated". If so do it and see if it works.

On previous versions I always got them working using a variety of complex fixes and commands. I've been pleased that the method listed here has worked very well recently.

  • It should be noted that you need to plug into a wired connection when you do this. I had a similar problem ona Levovo S10 and Hardware Drivers couldn't find any drivers for it. Then I plugged it into the network, ran the hardware drivers wizard, and it found the relevant drivers and installed them no problem. – tj111 Sep 23 '10 at 20:21

I had this problem just two days ago.


First check you have the affected card:

sudo lspci -n | grep 14e4

Then check that you have the modules that are breaking your installation:

sudo lsmod  | grep "b43\|ssb\|wl"

(b43 and ssb are the offenders)

Then edit the kernel module blacklist file:

sudo gedit /etc/modprobe.d/blacklist.conf 

and add the following to the end:

blacklist ssb
blacklist b43

I then rebooted, re-ran the Additional Hardware tool (in the Administration menu) and it installed correctly and worked perfectly.

  • actually running these two lines (lspci .. , lsmod ...) yields empty response. What does it mean that I have the affected card? – LiorH Sep 23 '10 at 10:23
  • It means that you haven't. – Javier Rivera Sep 23 '10 at 10:51
  • so which card do I have? – LiorH Sep 23 '10 at 11:02
  • All these actions require super user permissions: sudo lspci -n | grep 14e4 – Phil Hannent Sep 23 '10 at 11:38
  • right, running these commands as super user doesn't change the result. nothing is listed – LiorH Sep 23 '10 at 12:15

You need to figure out which wireless card you have, and then let us know which one you have. I am quite sure it is Broadcom, but we need to know which chipset. That info can be found by typing lspci|grep Network in a terminal. No need to use sudo or anything.


Is the wireless on? If not, hold the "A" button (on the left) and press On (+). Worked for me :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.