69

I have recently installed GIMP 2.8.6 on Ubuntu 14.04 LTS 64-bit and for the first time when I opened it, two windows along with the main window were available, but now I can only see a single main window. How can I bring those default windows back?

GIMP main window

  • 1
    In the menu there is an option Windows/Single Window mode. Turn that off. – Jos May 5 '14 at 14:49
  • I have also had the tools disappear, especially when working with email attachments other docs. A stray press of the 'Tab' key makes the tools disappear/re-appear. – DanT Aug 13 '18 at 20:01
97

Since you recently installed GIMP and closed the Toolbox window, I would suggest to reset your window preferences because it would also restore the dockable dialogs and the Layers windows which is extremly handy when working with GIMP.

Navigate through Edit menu → PreferencesWindow Management → and click the button for Reset Saved Window Positions to Default Values. Then click Ok to close the Preferences dialog and restart GIMP.

GIMP Preferences dialog

I would also suggest to enable the single-window mode so that all these windows would be docked inside the GIMP's main window and ease the workflow when working with it. Enable it through Windows menu → Single-Window Mode.

  • 1
    Unrelated to the question at hand but may I ask how you did that screenshot highlight? It's really neat and I'd love to use it in the future. – Glutanimate May 7 '14 at 13:53
  • 2
    @Glutanimate See this question: How do I create highlights on a screenshot? (particularly, the answer given by Takkat). – Aditya May 7 '14 at 13:59
  • When I switched to the single-window mode, all of the docks was at right, but I wanted to be the toolbox at one side and the layers and other at the other side. I have not succeded without reset to the default value. I like single-window mode. Thank you for your answer. – Arpad Horvath May 17 '15 at 19:42
  • This is terrible advice. I just lost a year's worth of settings trying to restore a single dialog. It doesn't even answer the question, it just assumes that the window OP wants is visible in the factory default. – felwithe Jul 4 '18 at 23:13
14

To open a new Toolbox, just hit Ctrl+b.

  • 3
    this is the result, simple, quick and reliable answer. Btw, how to get there without keyboard shortcut? – João Pimentel Ferreira Jul 7 '17 at 19:15
  • 1
    Works like a charm. – JCasso Sep 18 '17 at 12:35
  • This works, but I can not do it on GUI? – Ives Jul 10 '18 at 2:55
7
rm -r ~/.gimp-2.8

When gimp starts again it regenerates this directory, and you'll get gimp fresh and clean :)

  • 3
    But this will remove ALL of your GIMP config – Zanna Mar 25 '17 at 8:29
  • true. but the context is that you have a fresh gimp installation and you are not yet familiar with it. when I reset my gimp configuration I was still unable to use it properly until I deleted the init directory – Radi Csaba Apr 11 '17 at 10:54
  • Genious! Saved me a bunch of time. – Gabriel Staples Feb 10 '18 at 2:14
  • Better to just rename it, so 1) Gimp creates a new one and 2) you can copy stuff (brushes, patterns... ) from the old one. – xenoid Aug 14 '18 at 17:15
  • I believe the relevant file is .gimp-2.8/sessionrc, so one could just move that one to avoid losing everything else, and a fresh one will be created. And of course, it's a better idea to keep it as a backup/reference instead of deleting it completely. – Ratler Nov 27 '18 at 12:55
1

For GIMP 2.10, either:

  1. Click TAB, or
  2. Windows menu → untick 'Hide Docks'
0

In increasing order of destructive power:

  • Just hit the Tab key (or use Windows>Hide docks), this toggles the visibility of existing dialogs
  • See if the dock is still listed in Windows>Recently closed docks>... and reopen it
  • Windows>Dockable dialogs>Toolbox to get a new one (or reopen the hidden one if it exists)
  • For the intrepid: edit the sessionrc file in your Gimp profile with a text editor and check the coordinates of the missing dock/dialog, it could be set off-screen (for instance if you used a second screen in the past). If so fix the coordinates. If you break things, see the next two steps.
  • Edit>Preferences>Windows management>Reset saved windows positions to default values
  • Erase the sessionrc file in your Gimp profile (this is normally the same as the previous item)
  • Erase/rename your Gimp profile to make Gimp recreate an all-defaults one. If you rename it you can later copy useful things (brushes, gradients and other assets you added yourself) from the old profile to the new. But this is pretty much the nuclear option, rarely useful for just a missing dialog.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.