13

When using the volume buttons (+, -, mute) there is no reaction, neither on laptop keyboard nor on USB keyboard. No popup, no volume change, and no sound indication.

Volume control with the mouse works fine.

The buttons are working and get recognized:

Checked with keyboard system settings tool: they get recognized by the tool both from the laptop directly as well as from my USB keyboard.

Who can help?

  • I had to bookmark this question because this happens so much. – Matt G Jan 25 '17 at 17:58
30

Looks like a known bug on Launchpad.

According to the thread, the current fix is to...

  1. Open terminal (Ctrl+Alt+T)
  2. Type the following three commands to reset the volume/mute keys on your keyboard...

    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute
    

It worked for me, hope it works for you too.

  • 3
    Mine stopped working right now and this solution didn't fix it – matteo Aug 5 '14 at 21:27
  • Doesn't work for me. Creating new user works (with original volume keys) And for the existing user ONLY different keys work. So strange. – niry May 7 '15 at 6:20
  • As for my previous comment, this is after upgrading to 15.04. – niry May 7 '15 at 6:33
7

If resetting the keyboard shortcuts didn't work (such as in my case) move or delete the .gconf directory:

cd && mv .gconf .gconf.old

Logout and log back in again.

  • 3
    Also take note that some apps may store settings in this directory, in which case they will be lost. Guake is one program that stores settings there. – timetofly May 11 '15 at 14:40
2

Additionally, to fix the mute button, execute

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute

from a shell. Worked for me, hope it helps you too.

  • thank you worked perfect ... that was the last missing part. – ohoservices Jul 23 '14 at 22:37
1

I think I may have fixed this by reinstalling lightdm (Be careful to reinstall and not to remove it since that might cause issues with rebooting). None of the other solutions worked for me.

sudo apt install --reinstall lightdm

update: This happened again and this time reinstalling lightdm didn't solve the problem. What worked instead was this: 1) I installed dconf-editor and reset the value /org/gnome/settings-daemon/plugins/media-keys/custom-keybind‌​ings/ to default, keeping a copy of its value in a file. 2) After logging out and logging in again I reinserted the original value (i.e., my custom shortcuts). Now, everything seems to work again.

  • This problem keeps on occurring and this time again the previous solutions didn't work. Killing unity-settings-daemon solved the problem. It remains a mystery to me how to prevent this from re-occurring. Any pointers would be much appreciated. I should add that I run Ubuntu 16.10. – bilbo Feb 12 '17 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.