4

I installed Xubuntu 14.4 LTS dual boot with Windows 7. My hard disk is an SSD disk (where both xubuntu 14.4 and win7 are installed - in a different partition). I first installed Windows 7 and then I installed xubuntu. Xubuntu loads without errors/warnings. But when I try to choose Windows 7 from the grub I get the following warning/error:

setting partition type to 0x7
failing writing sector 0x0 to 'hd0'

Then asks to "press any key" and after a while Windows 7 boots without a problem. Why I have this warning/error? I tried to $ sudo update-grub inside xubuntu without any success.

update: this is my fstab and grub.cfg http://pastebin.com/vpbhLQLw

2

I found the solution for the above problem. My bios had a setting for "Fixed disk boot sector" and it was set at "Write Protect". I changed the option to "Normal" and the warning/error message disappeared!

Bios settings for boot sector

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.