1

My fresh Ubuntu 14.04 box was able to detect an USB modem and successfully connected to internet, though I found connection is sometime shaky. But the joy lasted only few days. Now, If I remember correctly, after having a regular system update the system is no more able to detect the USB modem. However the device is listed in the lsusb result. In the Network Management menu, I can't see the Enable Mobile Broadband option any more.

On the other hand, My laptop that also running Ubuntu 14.04 can still successfully connect the device to internet. Any diagnostic steps, suggestions are highly appreciated..thanks

1

The following solution worked well for me. I am jotting down the solution by hoping it could save the day of some other folks that having the same issue.

  1. Find out the name of your USB modem using the terminal command lsusb. I have got the following output

    Bus 002 Device 007: ID 12d1:1505 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard

note down the Vendor ID and Product ID of the modem. In my case it is 12d1 and 1505

  1. Create a config file in the /etc/usb_modeswitch.d directory. You can name the file as you wish. I have choosen the name as 12d1:1505.conf. Open the file in editor and add the following lines to it and save. You should use your Vendor ID and Product ID

    *DefaultVendor= 0x12d1 DefaultProduct=0x1505

    MessageContent="55534243123456780000000000000011062000000100000000000000000000"*

  2. Run the following command

    sudo usb_modeswitch -I -W -c 12d1\:1505.conf

Now hopefully you should see the "Enable Mobile Broadband" option in the network manager menu. If not then try to reboot the machine. In my case I was lucky enough to get detected the device as soon as I run the command.

  • Hi! How can be MessageContent got? – Regisz Nov 21 '14 at 10:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.