1

I am aware that similar questions have been posed already, but after several tries, I still haven't found a solution. Any help is much appreciated.

I have installed Ubuntu 14.04 on my new thinkpad x1 carbon using the default "erase and install" option (the laptop came with Windows 7 and has both Legacy BIOS and UEFI - the Legacy BIOS is enabled). At first, I was able to boot into Ubuntu, however, the boot time was very long and sometimes the grub menu appeared and I had to set root and prefix myself to boot into Ubuntu. Running Boot-Repair indicated that the problem was that the boot files were located far from the beginning of the disk and that the BIOS therefore had problems finding them. To remedy this, I created a boot partition at the beginning at the disk using gParted and Boot-Repair. However, this didn't solve the problem - not sure why. So I decided to start all over - i.e. merge the boot partition back into the partition with the Ubuntu installation and do a fresh install ("erase and install").

Apparently, this made things worse. When I turn on the laptop, it simply displays "Read Error" (after the BIOS messages). My suspicion is that the Master Boot Record (MBR) got deleted during the partitioning. (I seem to remember that the first partition started at 1MB before I partitioned the drive, but now starts at zero). I have tried to restore the MBR with Boot-Repair (which is done successfully according to Boot-Repair), but when I then try to do the "Recommended Boot repair" afterwards it gives an error (also saying "Please do not forget to to make your BIOS boot on sda disk!"). The Boot-Repair URL log is here http://paste.ubuntu.com/7395389

Any help is much appreciated - thanks.

UPDATE:

I have tried deleting all partitions on the drive using GParted and then installing Ubuntu with default setting "erase and install". Installation went well, but when the laptop is turned on it enters the "grub rescue". "ls" gives "(hd0) (hd0,msdos1)", "ls (hd0,msdos1)" gives "(hd0,msdos1): Filesystem unknown" and "error: failure reading sector 0x802 from 'hd0'". Issuing the command "ls" and "ls (hd0,msdos1)" makes the laptop think for a while. After typing "ls (hd0,msdos1)" a second time, I got "error: no such partition".

1

Use g parted magic usually on Hiren's Disc to delete and current os's on HDD/SSD and leave unallocated then install should be simple and fast.

  • So you are saying that I should delete the partitions first and leave the entire disk unallocated and then install Ubuntu? I have a Ubuntu-live-usb, so I could use gParted (again) for this, right? – Kristian Gregersen May 4 '14 at 22:53
  • Right. Gparted would do just fine. – hmayag May 4 '14 at 23:00
  • Okay, thanks. Do you have recommendations regarding the partitioning - is it necessary to have a boot partition at the beginning of the disk? – Kristian Gregersen May 4 '14 at 23:05
  • I've never done as the OS will ask if you want to partion it. – alston1992 May 4 '14 at 23:36
  • You can leave the partitioning up to the installer. This is best unless you have experience and a need to do otherwise. – Elder Geek May 4 '14 at 23:42
1

It turned out to be a hardware error. I contacted Lenovo support and was guided through a series of tests including opening up the laptop and removing the SSD and reconnecting it. They send a new SSD (under warranty) and now it works perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.