I have hplip-3.14.4 with an HP Photosmart b210a and recently it has stopped printing properly.

The issue is that it tries to print from the photo tray (which we don't use).

I've tried setting this manually via the Settings page, but it makes no difference. My wife has the same issue (also using Ubuntu 12.04, and lately with 14.04).

EDIT: I've just set the printer up in Windows 7 and it works. So this is not a hardware fault and likely due to hplip or some Ubuntu software issue.

Rolling back the driver to 3.13.8 does not make any difference. What else can I try

EDIT2: I upgraded to HPLIP-3.14.6. This seemed to fix the issue until I rebooted which caused it to return. I've also noticed that clicking on the HP icon gives a menu with several options listed twice. enter image description here

I'm also often getting a communication error with the printer.


I had a similar problem, printing through a CUPS server (also running Ubuntu). The solution to my problem was to remove the printer and re-install it on the client machine.

| improve this answer | |
  • 1
    This appears to have worked on multiple occasions. I guess I'll just have to get used to doing it regularly. Shame, as it takes a while, but it is the right answer! – James Bradbury Apr 16 '15 at 16:20
  • It may need the "optional dependency" cups-ddk. – James Bradbury Jun 5 '15 at 6:11

The problem appears to have been fixed by the update to cups and various libcups packages, marked as 1.5.3-0ubuntu8.3, 1.5.3-0ubuntu8.4. I received this on Mon 18th July.

Periodically it stops working again after some new update. I've had some success with using HPLIP Toolbox as suggested here, but reinstalling the driver (even if it hasn't been updated since the last install), seems to help as well.

Hope that helps someone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.