15

I have a Brother HL-3150CDW printer, installed the driver from their website, and I can print fine, except that Duplex (double sided print) is not available.

I've tried from a Windows computer and it works there, so I know it's possible. Any ideas on how this can be fixed in Ubuntu? (I'm on 12.04)

Source

4 Answers 4

8

Just worked this out! Ignore the "duplex" section of the print dialogue. Instead:

Print dialogue > Device > Two-sided > Long-Edged Binding > OK

Using Evince, for example:

  1. Select File > Print.
  2. Click the Page Setup tab.
  3. Set Two-sided to: Long Edge (Standard)
  4. Click Print.

Two-sided

3
  • 3
    There is no two-sided option available in ubuntu 16.04
    – Behnam
    Sep 20, 2016 at 17:55
  • 1
    For me on ubuntu 14.04 the option "Long Edge" disapears after each printing. I have to remove .config/evince/print-settings every time. After this all options are available again. Dec 21, 2017 at 16:07
  • 3
    In 18.04, the only option available for to the user is "one-sided" on this dialog, despite the printer being capable of printing with the command lpr -P HP-OfficeJet-Pro-6978-Direct -o sides=two-sided-long-edge file.pdf. Jul 6, 2018 at 3:53
7

Dumbest thing in the world but worth checking:

I had installed a printer via CUPS which could duplex-print via Google Chrome (Two-sided printing checkbox shows up and works) but didn't have a duplex option under the system dialogue:

enter image description here

The system print dialogue wouldn't allow me to select Page Setup > Two-sided > Long Edge (Standard) until I toggled this on under Printers > hit little gear next to the printer > Installable Options:

enter image description here

6

I have a similar problem with an EPSON XP-415 printer which, in Windows, can print two-sided, although only with manual intervention half-way to put back the one-sided printed paper in the loader.

The method to print two-sided:

  1. Print only odd pages
  2. Flip and load back in the paper rack the group of pages printed
  3. Print only even pages
1

Thanks, a similar thing worked for me in Evince. Although for me, the option is under the print dialogue's Advanced tab, the tab contents are called "General", and it's the first option, "Two-sided" (and in my case, I wanted it set to Long-Edge Binding", as you did.) This is despite the under the Page Setup tab, in the section labelled "Layout", Two-sided was greyed out and marked as "Not available".

Thank goodness, too, since Acroread was printing without the footers (go figure - yay, Adobe!), whereas evince works just fine.

I'm using Ubuntu 16.04.2 LTS - I don't know why Campiador sid there is no two-sided option available - perhaps he's referring to the (bug?) that leaves it greyed out in the Layout section?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .