1

I am only interested in getting into my system on my LAN. I've got my firewall set up so that it blocks incoming packets that are not from the LAN. I can SSH into my Ubuntu machine but I can't VNC into it from my Mac. I've tried the built in Mac viewer (from the Go menu) and RealVNC's viewer for Mac. Neither work.

I'm kind of stumped.

I know that using it via SSH is the usual configuration but I don't want to use it through an SSH tunnel in this case as I am confident that my LAN is secure and not even my SSH terminal is visible outside of my LAN.

Is there some configuration option missing? I'm using Ubuntu 14.04.

As an edit, trying on my Mac gets an error message saying that the VNC version is incompatible. Also, I did try to setup the SSH tunnel as well, it didn't work either.

  • Can you VNC into your own system? I.e., from your Ubuntu machine can you connect to "localhost", using, e.g. Remmina? – Jos May 4 '14 at 19:15
  • Yes, I can. Works just fine. Also I can go the other way, I can connect to and use my Mac both from the SSH tunnel (how I usually get to my Mac) and on the LAN without the SSH tunnel. – TitanShadow May 5 '14 at 2:47
0

Found my own answer! If anyone needs to know the cryptography being used by default for VNC in the default vino-server configuration has issues with encryption and authentication. I finally found the answer which is a reference to this bug report from RedHat I found the solution in a post here about gnome3 and connecting via Windows which both point to vino advertising using TLS for encryption and authentication.

Using the command:

gsettings set org.gnome.Vino require-encryption false

Now, it should be noted that doing this in anything where you are unsure, in any way, about your network (or you're exposed to the Internet at all). Using SSH becomes so much more important when encryption is disabled. And the authentication is weak. Just thought it was worth mentioning.

0

In the ubuntu software center I downloaded X11VNCserver. Made sure the ubuntu (14.03) desktop was up to date, then restarted the machine. I can now connect to the Ubuntu machine with my mac using Go to Server and typing in vnc://ip-address

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.