1

I am using Ubuntu 14.04 with gnome 3. I have multiple wallpapers in rotation. When I suspend my computer and I go back, my wallpapers are merged as you can see here :

background merged

In addition, I can't do a right click on my desktop.

Is there something to do to solve this problem?

5
  • try this gsettings set org.gnome.nautilus.desktop background-fade false or gsettings set org.gnome.nautilus.desktop background-fade true – kenn May 7 '14 at 9:20
  • It's hard to say if it works. The problem does not occur every time. I will try one setting and another if the problem persist. – Dougui May 7 '14 at 9:26
  • I wonder if both of the pics are from the same directory. I have wally wallpaper switcher, during switching wallpapers it's using a default gnome wallpaper in-between. – kenn May 7 '14 at 9:32
  • What application are you using to "rotate" the wallpapers? – jobin May 7 '14 at 11:57
  • 2
    While I understand how this could be annoying I have to say that is one of the most beautiful bugs I have ever seen. – Glutanimate May 11 '14 at 13:35
1
+50

This sounds like a bug. When this happens, try pressing Alt+F2, type r and press enter. This will re-initiate your GNOME session without logging out or closing any applications.

2
  • It works but I don't think it's a definitive solution. – Dougui May 10 '14 at 0:26
  • Right, this is only a temporary work-around while the bugs are being worked out. – HarlemSquirrel May 12 '14 at 17:57
0

Use this in terminal:

gsettings set org.gnome.settings-daemon.plugins.background active true (or false)

A site: http://lifehacker.com/5581364/reset-gnome-when-things-go-wrong-on-your-linux-desktop

Or reset your gnome desktop. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.