I recently installed Ubuntu server on my server and I found out it had no GUI by default. So I installed it with the help of this page

Everything seemed to be fine so I started copying some files to my server. When I checked it to see if it was done I saw the lock screen that asked for the root password. But I never set that password so I tried the password which I set for my user account. I have also tried some other different passwords. I searched the internet and found out that there is no default password for root.

Am I stuck in this lock screen?

How should I shut the computer down? (there is no shutdown button in the lock screen)


ctrl+alt+F1 will drop you into a terminal where you can log in and restart X with:

sudo service lightdm restart

You could also just stop it with stop in place of restart.

Maybe a silly question but did you you try just pressing enter? Usually the root/admin password and the user password are the same, assuming the user is also an administrator and you haven't changed you password. I'm guessing since you are getting a lock screen, you are using a graphical user interface like gnome or unity. Make sure you are logged in as you and not as guest and that your account has admin privileges.


If you are asked for root password at Log on Screen and don't know the password, follow these steps:

  1. Press Ctrl+Alt+F1 to get to Terminal screen.
  2. Type your login name and password.
  3. Type the command, sudo passwd root.
  4. It will ask to enter password three times where first password is your login password, second is new root password and third is also new root password for new root password confirmation.
  5. Press Ctrl+Alt+F7 to get back to GUI which is Log on Screen.

The above steps are given to modify your root password. So, temporarily, you could get yourself logged in and to work if you don't want to reboot.


Not sure why your running a gui on a server, but if you do go ahead and set a root password (kinda a security risk) make sure to set "Permit root login" to no in sshd_config

sudo nano /etc/ssh/sshd_config

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.