I was running Ubuntu 13.10 with no issues and decided to upgrade to Ubuntu 14.04 recently. Since I've upgraded I've noticed that my mouse starts to lag after I play a movie via xbmc or a video on Youtube in full screen mode.

It usually happens after playing a fullscreen video for around an hour. My mouse works perfectly on startup.

I have just tried a fresh install of 14.04 and I've got the same problem.

When I say the mouse lags, I mean that after I move the mouse it takes 1-2 seconds to respond and is continuously lagging ie. once it starts lagging it's constant and I have to reboot to fix the problem. I've tried restarting x but that doesn't fix it.

I am using a Logitech K400 mouse/keyboard combo with a logitech unified receiver.

Any suggestions?


5 Answers 5


I actually found the issue to this problem and thought I'd do the right thing and post it. It would seem that the positioning of the bluetooth receiver in particular USB ports had an impact with the reception between the keyboard/mouse (probably something to do with the fact that it's a mini-pc and the processor and other radio affecting devices are situated so closely together and so close to the USB ports).

I changed the logitech bluetooth receiver to a different USB port and my mouse/keyboard are working like a charm now.

Thank you to everyone for their input and help!

  • 1
    Thanks. Thought it might be something to do with the drivers. But simple switching of receiver to another USB port fixed it.
    – Akh
    Jun 15, 2016 at 17:53
  • 1
    Very interesting that this worked for me with a Logitech G602 and the unified receiver. I wouldn't have thought to try it if not for this thread. I was actually on BunsenLabs (Debian-based distribution) and the solution was the same. Thanks! Mar 15, 2017 at 15:15

I had the same problem, but i fixed it. You need to install "CompizConfigSettingsManager" and switch off "sync with VBlank" in OpenGL tab. After that i installed PPA and update drivers for video card. It helped me. Here is video solution: http://www.youtube.com/watch?v=cIQZv6MXzno

  • Thanks for your response but this answer is related to graphics performance, not mouse lag.
    – gyrex
    May 6, 2014 at 22:54
  • I had problem with windows rendering and applications speed. Mouse lagging was just one side of the issue. Good luck. May 7, 2014 at 5:36
  • I experienced severe mouse stuttering also, and disabling "Sync with VBlank" fixed the issue. Thank you!
    – sirdodger
    Dec 15, 2014 at 20:07
  • Thanks for this; it seems to have fixed my problems with lagging keyboard and mouse input on 14.04. I didn't need to update drivers; I had a big improvement by just installing ccsm (apt-get install compizconfig-settings-manager) and disabling the "Sync To VBlank" checkbox. To find the checkbox, run the command 'ccsm', and click "General > OpenGL"
    – Bill Agee
    Aug 20, 2015 at 18:52

This can occur if your bluetooth dongle is next to a wifi chipset for example. Just switch side to connect my USB dongle solved my laggy keyboard (my mouse was already fluid before).

A fresh install rather than a upgrade is always cleaner.


I cannot find a solution to my problem so I am going to downgrade to 13.10. This is a real shame since I would have liked to run a LTS release of Ubuntu.

  • Do not despair. It is normal to have incompatibilities and bugs in any release, LTS or not. You can always install some of the follow-up releases of the LTS (14.04.x when they become available) where (I'm sure) most of the bugs will be ironed out.
    – hmayag
    May 12, 2014 at 20:25
  • Thanks for your response. FYI, I re-installed 13.10 and my mouse issues are non-existent.
    – gyrex
    May 13, 2014 at 0:13

This solved this problem, although kernel dowgrade is not a good thing:

sudo apt-get install linux-image-3.4.0-3-goldfish
  • If it works then it's good enough. Newer isn't always better my friend.
    – hmayag
    May 12, 2014 at 20:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .