6

I'm using ubuntu 14.04, here in the 'login screen' the password field is disabled, this issue also occurs sometimes during 'lock screen'. I don't want to remove password from my account nor do i want auto login. My account is with administrator privileges.

Going to terminal using Control + Alt + F1, then back to GUI with Control + Alt + F7, doesn't enables the password field.

  • may be resetting/reinstalling unity will help? – Null pointer May 4 '14 at 4:43
2

I'm having the exact same issue. Edit: Looks like this is a confirmed bug: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1311316

2

I was having the same issue and went to the terminal via Control + Alt + F1, logged in through terminal, then executed the unity command, then went back to the GUI with Control + Alt + F7 and my system resumed to where I had left it. No restart required.

  • This worked for me, although I executed unity --replace instead of just unity. However, the cause of this is frustrating. – Nathan S. Watson-Haigh Nov 27 '14 at 3:55
  • I've tried unity, unity --replace, and compiz --replace and what I got was a single window maximized across both monitors. There was no menu bar and no way to access the desktop. – FrustratedWithFormsDesigner Jan 9 '15 at 21:39
  • Note that this solution only partially works for me when I have multiple users logged in. When unity comes back up, it logs me in as one of them, and the other one's state (windows, applications) is lost, and there's no way to switch users. – BlueBomber Feb 13 '15 at 19:07
1

I found a very nice work-around in comment 166 of the bug report (https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1311316):

  • Switch to a tty (e.g. Ctrl+Alt+F1)
  • Log in
  • Run: sudo loginctl unlock-sessions
  • Switch back to the Desktop: Ctrl+Alt+F7 (or F8).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.