1

I am compiling a fortran program by using g77 on Ubuntu 14.04, I got the following error:

ubuntu /usr/bin/ld: cannot find -lgcc_s

Didn't you ever have experience with such problem?

2

You are missing a library. This command should install the necessary dependencies:

sudo apt-get install lib32z1-dev

Source: https://stackoverflow.com/a/5850955/1505348

  • 1
    That command installs libz and has absolutely nothing to do with the missing libgcc_s.a, which is almost certainly caused by static linking, not the absence of any variant of libgcc_s. – Jeff Sep 4 '16 at 0:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.