2

I bought the Netgear A6200 USB wireless adapter, and I used WINE to run the installer from the disk that came with the adapter, but it failed part way through. Is there any way to get this to work?

6
  • 1
    You might try the files at post #7 here: forum1.netgear.com/showthread.php?t=79948
    – chili555
    May 3, 2014 at 22:10
  • I'm not familiar with Ubuntu. How do you use ndiswrapper to load .inf files?
    – thechemEnt
    May 3, 2014 at 22:13
  • Also, tried the method on post 7, but it still isn't working. After I try it and type "ndiswrapper -l" is says "bcmwlhigh5 : driver installed" But....when I plug in the USB adapter, it doesn't work.
    – thechemEnt
    May 3, 2014 at 22:28
  • 2
    So, after doing a little digging, I got it to work. You do get far enough in the install using WINE for this to work properly. Here are the steps: 1. Open the shell, and type in cd .wine 2. cd drive_c 3. cd Program\ Files\ (x86)/ 4. cd NETGEAR 5. cd A6200 6. cd Drivers 7. sudo diswrapper -i nameoffile .inf 8. sudo modprobe diswrapper 9. sudo ndiswrapper -m And that got it to work. Note: The adapter did NOT work until after the command sudo modprobe diswrapper
    – thechemEnt
    May 3, 2014 at 22:52
  • Glad it's working! Great job.
    – chili555
    May 3, 2014 at 23:23

3 Answers 3

3

With Ubuntu 14.04 I did the following steps:

sudo apt-get install ndisgtk
wget www.mediafire.com/?od9wpw6ccrnyhaa
unzip A6200_Linux_drivers.zip
sudo ndisgtk

Then when ndisgtk is running, choose the file ending in "ing" that was unzipped. It should be bcmwlhigh5.inf. Once that is installed you can select a wifi network from the Network menu-bar item.

2
  • wget didn't work... had to go to the link directly in a browser Sep 3, 2016 at 2:27
  • I also don't know how to confirm that it's working, and that I'm not using my internal wifi card Sep 3, 2016 at 2:29
1

Solved with https://github.com/jurobystricky/Netgear-A6210 - plug your device out before the following commands:

git clone https://github.com/jurobystricky/Netgear-A6210
cd Netgear-A6210
make
sudo make install

If your device was plugged in before the above steps, unplug and re-attach, the OS will detect and you should see available Wifi hotspots

0

The solutions I found, including the ones given here, did not work for me unfortunately. Seems to be some issues with newer kernels.

However, I just found out what works for me. The following github repository contains many non-free and proprietary modules including one for the mt7662 chipset which is used in the Netgear A6200/A6210.

Had to simply clone the repository in /lib/modules/ and modprobe mt76-usb and she now works like a charm. Hope this helps those who also had trouble overlooking this simple option.

See https://github.com/NXP/linux-firmware

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .