25

After upgrading recently, I noticed that when running Chromium, there is a new bell icon in the system indicators area in the upper right. The menu gives the options as such:

  • Chromium - notifications
  • Do not disturb
  • Do not disturb for one hour
  • Do not disturb for one day

Are these options only available via the system indicators menu, or can I remove this icon from my view, and access the same options somewhere else? How would I go about removing this?

  • Can you try going into settings and disable running background apps? – saiarcot895 May 3 '14 at 18:47
  • I see the option for "Continue running background apps when Chromium is closed", but that is already unchecked. – B Johnson May 6 '14 at 4:17
  • 1
    What version of ubuntu and chromium are you using? I don't see a bell shaped icon in the system indicators area on 14.04 using chromium 34.0. Also, which desktop manager are you using(unity, gnome, KDE, etc)? – jobin May 27 '14 at 17:50
  • @Jobin The notification icons where added with chrome/ium 35.x. – Glutanimate May 28 '14 at 10:03
15

Open the URL chrome://flags in the browser. Now disable these flags:

  • #enable-sync-synced-notifications
  • #enable-google-now
  • #device-discovery-notifications
  • #enable-experimental-notification-ui (Chrome/Chromium 34 only)

Click the restart button at the bottom of the site.

  • I tried disabling only google-now option but the notification came back again... After disabling all these above, there is no notification icon any more... Thank you! – Mladen B. May 30 '14 at 13:25
  • 1
    @MladenB. What happens when you set a YouTube video to full-screen? Does the icon reappear? – Glutanimate May 30 '14 at 14:09
  • @Glutanimate, I just tested with YT and the icon doesn't reappear. – Mladen B. Jun 1 '14 at 8:54
  • @MladenB Ok, thanks for looking into that. It does reappear for me, strangely enough. Looks like it's quite temperamental. – Glutanimate Jun 1 '14 at 9:14
  • @Glutanimate, it might be completely unrelated, but try to disable the option "Continue running background apps when Google Chrome is closed" in the Chrome's Settings page. – Mladen B. Jun 1 '14 at 9:20
6
+25

Edit:

I found a very hackish but surefire way to hide the panel indicator.

Simply replace the stock indicator with this one-pixel transparent PNG file (right clickSave link as to download the file).

Instructions on replacing the indicator may be found here.

Original answer:


There are various discussions about this on Google's product forums. The only solution I've found that partially works is to disable Google Now in Chrome's flags:

  1. Navigate to chrome://flags/#enable-google-now
  2. Set the flag to Disabled
  3. Restart Google Chrome

However, even with this flag disabled the notification icon can reappear under some circumstances:

The Notification Bell seems to reappear consistently when i fullscreen a Youtube Video, even after deactivating "Google Now" and anything that even mentions "Notifications" in the flags settings.

--- Source

Google's official statement on the matter isn't very satisfactory, either:

Hi All,

As mentioned on the flags page, those are experimental tools that can get removed at any time. We are working on improving the notification system and your options around controlling when to see them, which will be included in upcoming releases. For Windows users, please try clicking on system tray, customize link, which will open your control panel. You can then change the settings for your notification area icons for Chrome from there.

- Sarah

--- Source

I guess we will have to wait for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.