I have HP probook 4520s Core i5 it comes with SUSE enterprise 11 and everything working but when I removed it and installed Ubuntu I got I problems with drivers nothing working

  1. Graphic is ATI Radeon HD 6370.. ubuntu hardware found driver for 6300M and I installed it but I still have problem it is wrong driver

  2. synaptic toucpad right click isn't working also turn on/off key isn't working . I tried synaptiks but it didn't solve anything

  3. I've problem with wireless /bluetooth the keyboard wifi key led becomes crazy . its light keeps going on and off continuously ( red -white - red - white .......)

I tried fedora 15 and I got the same problems I found drivers on hp for SUSE enterprise 11 I tried to use synaptic driver but it didn't

SUSE drivers on HP site : HP ProBook 4520s Notebook PC

closed as too broad by Braiam, karel, chaskes, qbi, LiveWireBT Nov 4 '13 at 9:46

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • You asked several question in one. It might be better to research if your questions are answered on this site and if not, split your questions into several single ones. – qbi Nov 4 '13 at 8:19

http://ubuntuforums.org/showthread.php?t=1600498 there are wifi drivers ;)


I had the same problems with my HP, with the light to turn on wifi or the definition of the screen. I search but found nothing, so experimented to find the solution.

  1. Download the installers drivers of Synaptic

  2. Look for these installers, only search your computer (I think they are .deb) and copy

  3. Uninstall the drivers through Synaptic.

  4. Reboot, install the drivers through synaptic (the .deb) you just downloaded)

Restarted for the changes and go.

Well that served me with 11.10, I hope this have been helpful.


I had this similar problem and I resolved it by uninstalling the 32-bit Ubuntu I had installed previously and installing a 64-bit one.

My laptop(HP ProBook 4540s) is a 64-bit and I think the problem was because I was installing a 32-bit Ubuntu OS in it.

I hope this helps someone.

Not the answer you're looking for? Browse other questions tagged or ask your own question.