15

Dummy Output is shown in System Settings -> Sound in Ubuntu 14.04.

enter image description here

None of the other questions about this have solved my issue.

I'm using a Dell Inspiron N5110. The sound on my Ubuntu 14.04 is driving me crazy. It works and doesn't work randomly as I turn my PC on.

I have followed steps for 13.10 and the answers to No sound in Ubuntu 13.04, only Dummy output device listed, but nothing seems to fix the issue.

After following the instructions in Ubuntu Documentation Hda Intel Sound Howto. Currently I have dell-s14 in the alsa-base.conf file. I can hear sound from my laptop speakers after I saved and restarted alsa, but lost sound after rebooting. Changing it from dell-s14 to dell-vostro-3500 didn't work. Running pulseaudio -D gives Daemon startup failed.


cat /proc/asound/card0/codec* | grep Codec`

gives

Codec: IDT 92HD87B1/3

and here's the section matching my codec in the HD-Audio-Models.txt

    STAC92HD83*
     ===========
    ref     Reference board
    mic-ref Reference board with power management for ports
    dell-s14    Dell laptop
    dell-vostro-3500    Dell Vostro 3500 laptop
    hp-dv7-4000 HP dv-7 4000
    auto        BIOS setup (default)

pulseaudio -vvv

gives:

I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
        D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
        D: [pulseaudio] core-util.c: RealtimeKit worked.
        I: [pulseaudio] core-util.c: Successfully gained nice level -11.
        I: [pulseaudio] main.c: This is PulseAudio 4.0
        D: [pulseaudio] main.c: Compilation host: x86_64-pc-linux-gnu
        D: [pulseaudio] main.c: Compilation CFLAGS: -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -Wall -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
        D: [pulseaudio] main.c: Running on host: Linux x86_64 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014
        D: [pulseaudio] main.c: Found 4 CPUs.
        I: [pulseaudio] main.c: Page size is 4096 bytes
        D: [pulseaudio] main.c: Compiled with Valgrind support: no
        D: [pulseaudio] main.c: Running in valgrind mode: no
        D: [pulseaudio] main.c: Running in VM: no
        D: [pulseaudio] main.c: Optimized build: yes
        D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
        I: [pulseaudio] main.c: Machine ID is 41cf9ca67be1059b2fa9e2fd533d698b.
        I: [pulseaudio] main.c: Session ID is c2.
        I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
        I: [pulseaudio] main.c: Using state directory /home/me/.config/pulse.
        I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-4.0/modules.
        I: [pulseaudio] main.c: Running in system mode: no
        E: [pulseaudio] pid.c: Daemon already running.
        E: [pulseaudio] main.c: pa_pid_file_create() failed.

Update

After I added both dell-vostro-3500 and dell-s14 to the alsa-base.conf and restarted my PC and logged in, there was no sound tray icon, I logged out and logged in, and I got the sound back!!

1
  • None of the answers here solved the "dummy output" problem for me either, but, I knew if I reboot it would work, I just didnt want to (neither wanted to logout). So, I login with another user and pulseaudio got initialized properly! I just logout it and it is working again on my main user! I would like to know a command to use on the current user to do that tho, pulseaudio -k (that auto restarts) makes no difference... (neither any answers I found that didnt involve driver installation or reboot and so on...). Btw, I had also to use the command pulseaudio -vvv and it is working better now. Sep 10 '16 at 2:11
10

I added my user to the 'audio' group and after re-logging in, it was fixed.

usermod -a -G audio $USER

I noticed when aplay wasn't able to list devices as a user:

Listing with with my account:

aplay -l  

aplay: device_list:268: no soundcards found

It didn't see any cards, but when listing with root (sudo):

aplay -l 

\*\*\*\* List of PLAYBACK Hardware Devices \*\*\*\*  
card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]   
Subdevices: 1/1    Subdevice #0: subdevice #0

it saw them all.

I don't know why this was necessary, because on my other machine the group exists, and my user isn't part of it either. It did work though.

0
6
+50

I checked the sound card information you provided and this is what I came up with. According to what I found by searching the internet, you have to edit the alsa-base sound configuration file and add either dell-s14 or dell-vostro-3500 to it. Your Dell Inspiron laptop is not a Dell Vostro, but it is a Dell laptop. Since there are only two alternatives to choose from, choose dell-s14.

If that doesn't work, I suggest you try dell-vostro-3500 because Dell Inspiron and Dell Vostro are similar in many ways. The Dell Vostro is a business version of the Dell Inspiron consumer laptop with some differences in the hardware and specifications.

Before you run the following commands read them first, and if you have already tried them comment, as it will save you from doing unnecessary work.

Open the terminal and type:

sudo touch /etc/modprobe.d/alsa-base.conf.bak
sudo cp /etc/modprobe.d/alsa-base.conf /etc/modprobe.d/alsa-base.conf.bak  # backup alsa-base.conf
sudo nano /etc/modprobe.d/alsa-base.conf 

This will open alsa-base.conf for editing in nano text editor. Scroll down to the bottom of alsa-base.conf and add this new line to the bottom:

options snd-hda-intel model=dell-s14

Press the keyboard combination Ctrl+O and after that press Enter to save the changes you made to alsa-base.conf. Press the keyboard combination Ctrl+X to exit nano.

Next run the following command:

sudo alsa force-reload  

The next time you reboot check to find out if the changes you made held up after a reboot.

0
6
sudo modprobe snd-hda-intel

This command uses modprobe, a tool for adding and removing modules from the Linux Kernel, to add support for the audio.

2
  • Thanks! That helped, when no other answer on the internet did.
    – cat
    Dec 8 '16 at 1:07
  • In my case I needed rmmod snd-hda-intel && modprobe snd-hda-intel
    – golimar
    Nov 5 '18 at 8:49
5

Following commands helped me in my case:

pulseaudio --kill
sudo alsa force-reload
pulseaudio --start

Found here http://itsfoss.com/fix-sound-ubuntu-1304-quick-tip/#comment-964131972


UPDATE 2016-01-29: I upgraded to 15.10 and have the same issue here. On 15.10 it's just enough to run

sudo alsa force-reload
0

None of these worked for me

I have downloaded driver from http://12244.wpc.azureedge.net/8012244/drivers/rtdrivers/pc/audio/0001-LinuxPkg_5.18rc8.tar.bz2 and installed it.

It is working now.

Not the answer you're looking for? Browse other questions tagged or ask your own question.