5

I have a windows 7 with vmware workstation 9, and I'm running Ubuntu 14.04 on it. I configured the shared folder in the VM/settings menu, and I can see it in the Ubuntu when doing vmware-hgfsclient. But there's nothing inside /mnt folder.

I've tried following this thread: How do I mount shared folders in Ubuntu using VMware tools? but it still won't mount (after numerous restarts and installing and uninstalling vmware-tools like suggested there), there's still nothing inside /mnt.

I've also tried all sorts of stuff I stumbled upon with open-vm-tools, but nothing worked.

I think I don't have vmhgfs, because modprobe vmhgfs return this:

modprobe: FATAL: Module vmhgfs not found.

So hacking /etc/fstab like suggested in many places shouldn't work anyway, right?

Any ideas on how to fix this?

1

As told here the problem seems to be VMWare Tools, and it gets fixed with Tools 9.6.2 version. The main problem seems that this version of Tools come with Workstation 10, not 9.

  • I changed my pc, so I won't be able to check your suggestion. thanks for your reply anyway – nivniv Jul 14 '14 at 17:21
0

What solved my problem was:

  1. Make sure you have all the prerequisites (gcc, make, binutils, kernel sources). What's missing from Ubuntu is only the kernel sources so first find out the kernel release

    > uname -r 3.19.0-26-generic

    Then install the right sources:

    sudo apt-get install build-essential linux-headers-3.19.0.26-generic --fix-missing

    The fix-missing is there because for me apt-get sometimes comes up with an error, it might be my internet connection.

  2. (Re)install vmware-tools by following the instructions in this page (basically extract the tar and call sudo ./vmware-install.pl -d)

  3. Configure vmware tools by calling vmware-config-tools.pl (Don't forget to answer yes when asked about enabling Shared Folders)

I did this on a clean Ubuntu 14.04 installation with VMWare Workstation 12

-2

I've tryed all this on VMWare 10 (diference here that I have kernel 3.13.0-77-generic on guest) and no progress... Any other possibilities?

  • -1 because this doesn't seem to be an answer. You might want to post this as new question instead. – clearkimura Feb 15 '16 at 5:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.