I have recently upgraded to Ubuntu 14.04, but startup disk creator tool is not loading the ISO image file. I have tried these:

  1. Startup Disk Creator not recognizing selected ISO in 13.10
  2. Startup disc creator not allowing any iso to be loaded

But still aren't able to solve this problem. Can you please help me in this regard? Thanks in advance.

  • I am familiar with the process of making usb bootable, here the startup disk creator not load the iso file and I can't get my answer in this link ...
    – cst
    May 3, 2014 at 8:32
  • It is not loading iso other than ubuntu. I hope there is a restriction Mar 28, 2015 at 9:16
  • The Ubuntu Startup Disk Creator in 14.04 LTS (and other versions before 16.04 LTS) was notoriously buggy. In that version of Ubuntu your should use another tool to create your USB boot drive. See this link and links from it, help.ubuntu.com/community/Installation/FromUSBStick, for example Disks alias gnome-disks or mkusb or in Windows Rufus or Win32 Disk Imager. - Startup Disk Creator works in Ubuntu 16.04 LTS and newer versions.
    – sudodus
    Mar 27, 2018 at 13:23
  • Had the same problem with Lubuntu 18.04 LTS. GiorgosK's answer worked well!
    – Rantanplan
    Nov 7, 2019 at 15:20

7 Answers 7


.iso file is seen by startup disk creator when opening other dialog but never gets selected (its like it does not really recognize this file extension) but this does not happen with all .iso files.

Just rename iso image to img extension

mv imagename.iso imagename.img

This has happened to be on 14.04, 16.04 and 18.04 but I assume is a glitch of the program and not ubuntu.

at least in my case I had to move img to Downloads folder otherwise "Startup disk creator" did not see it

mv imagename.img ~/Downloads/imagename.img

Then open "startup disk creator" and choose appropriate USB (img should be automatically chosen)

For more details on iso and img renaming look in How to create an .img file from .iso on Ubuntu?

  • Perfect!!! It worked...
    – Bee
    Jun 3, 2018 at 13:33
  • This fixed my problem
    – Vishrant
    Aug 31, 2018 at 2:49
  • 1
    As of 2019, using version 18.04 LTS, the application still explicitly mentions the extension 'iso', and not 'img'. How lazy can you get?
    – Adrian M.
    May 16, 2019 at 14:14
  • 1
    still 2019. if you have selected CD in the lower right corner (default) it expects iso. But the iso cont be read. Select the other option and it demands *.img. so rename it as abouve and be happy ;). thx for this post!
    – Cutton Eye
    Oct 4, 2019 at 10:33
  • 1
    This issue is still on Ubuntu 21.10
    – Draco
    Dec 15, 2021 at 13:34

You can use unetbootin for making bootable usb stick. It works out of the box.

  1. To install use the command sudo apt-get install unetbootin
  2. open from terminal with command sudo unetbootin and give your password.
  3. choose your iso image browsing the folder where you have kept it
  4. choose your usb stick
  5. click ok and wait until it is done.

It works pretty smooth in any platform.

  • Beware, unetbootin adds its own GRUB-like screen and as such, is more prone issues. Jun 16, 2016 at 3:16
  • 1
    Its important to add the PPA before step 1: sudo add-apt-repository ppa:gezakovacs/ppa && sudo apt-get update
    – Ferrmolina
    Nov 10, 2018 at 0:39
  • Both dd and unetbootin are extremely error prone. Use the pre-installed usb-creator-gtk. Remember to rename your .iso to .img Aug 17, 2019 at 23:55

Startup Disk Creator looks in the Downloads directory by default. If finds any ISOs it sticks and will only let you use that ISO with the highest number and Ubuntu in its name. I solve this by moving ALL the ISOs from my Download directory in another directory. Startup Disck Creator can't default to any ISO so it comes up blank. It will then let you select ISO's from other directories as normal.

My exact process is:

  1. Move all ISOs from ~/Downloads to ~/Downloads/ISOs
  2. Run Startup Disk Creator, Source table will be blank
  3. Click Other...
  4. Open ISOs from any location as normal (in my case ~/Downloads/ISOs)

Hope this helps

This is only based on my computers running 12.04.4. Your mileage may differ.

  • Thanks for your help. "If finds any ISOs it sticks and will only let you use that ISO" - wow, that's a ridiculous "feature". It even picked up some random .img file (not even Ubuntu related).
    – Jeff Ward
    Feb 17, 2015 at 23:41
  • 2
    @Jax-L - It did not work for me on 15.04
    – trex
    Jun 5, 2015 at 5:00
  • 3
    Didn't work for me on 14.04. It did show up as blank but wont load the selected ISO
    – JorgeeFG
    Jun 26, 2016 at 3:17
  • Rename the *.iso to *.img Aug 17, 2019 at 23:57

I am aware how old this thread is, but given someone with the same problem pointed me here when asking for advice, I thought I'd share my answer

The answer, alas, is to not use SDC, but the command line.

cd path/to/iso/dir
# (identify the flash drive - likely /dev/sdb or /dev/sdc or the likes)
# (you should be able to identify it by its size - or just remove the flash drive, run lsblk again, see what disappears)
sudo dd if=name_of_image.iso of=/dev/sdc # (as appropriate)

This will copy byte-for-byte the ISO to your flash drive, overwriting it completely. It will look like nothing is happening when you run the command, but that's just the 'dd' command - it's not verbose at all. Takes about 1-4 minutes depending on ISO side and write speed of the flash drive.

Note that if this is one of the official Ubuntu respins (Ubuntu, Lubuntu, Kubuntu, etc) then it should be fine to boot from flash disk. Other ISOs may not have compatibility for being written to and booted from a flash disk.

You can convert an ISO to "hybrid" (CD and USB compatibility) by installing the syslinux utility and running isohybrid (which will modify the ISO file itself - maybe do this on a copy of the ISO)

sudo apt install syslinux-utils
isohybrid path/to/your.iso

Good luck


in Ubuntu 16.04, moving the ubuntu iso's out of the Download Directory to a sub directory resulted in an empty CD-Drive/Image block. Clicking Other... navigating to Downloads and selecting Solus-1.2.1-MATE.iso and clicking open did absolutely nothing.

ls -lah *.iso -rw-rw-r-- 1 user user 971M Nov 9 11:22 Solus-1.2.1-MATE.iso


Do two things.

  1. Remove any iso (or img) from Downloads folder except for the iso you want to load. OR put all iso s in another directory under Downloads. Anyway, make sure there's no iso in the Downloads that you don't want to burn right now.

  2. Even still the disk creator is not recognizing, then change the iso you want to burn into .img by simply renaming it.

Remember to close and restart the Disc Creator after renaming.

This has helped me solve the above question more than a dozen times. Hopefully, it saves your time too.

  • Tried both dd and unetbootin. usb-creator-gtk is the only one that worked. Aug 17, 2019 at 23:59
  1. Go to Show Applications
  2. Select Utilities
  3. Select Disks
  4. Select your USB drive
  5. Under Volumes Unmount selected partition(Square icon under volumes information)
  6. Select Delete selected Partition( Minus icon next to square icon)
  7. Select Delete in new window
  8. when completed select additional partition options( Setting icon next to minus icon)
  9. Select Restore Partition Image... from list
  10. Select the folder on right in new window and select path to iso(Image to Restore)
  11. Select Start Restoring(will commence making bootable usb for you)

Another option is https://etcher.io/

When finished you now have your bootable USB.

Hope this is of help

Cheers Mooredeeb

Not the answer you're looking for? Browse other questions tagged or ask your own question.