13

I have software in a Windows XP Guest that acts as a server. I need to have my LAN computers connect to it. Is the best way to use a bridged connection? Is there another way?

I've tried setting up a bridged connection, and so far, it has an internet connection using br0, but the local computers on the LAN cannot access it.

Oh, and I'm using Ubuntu 14.04LTS 64-bit, and VirtualBox 4.3.10.

  • When using a bridged connection your guest will get its own IP address. So not the same as your host. If this still doesn't work, check the guest's firewall. – Louis Matthijssen May 3 '14 at 8:34
  • Are your lan computers and your xp on the same network? check out their IP address first.Turn off your xp firewall too as Louise said. – Mohammad Reza Rezwani May 3 '14 at 8:51
22

I've tried setting up a bridged connection, and so far, it has an internet connection using br0, but the local computers on the LAN cannot access it.

br0?!...It seems to me as though you have created a bridged connection in the host OS (Ubuntu), which is not the correct way.

Instead, go to VirtualBox, Select your Guest machine:

  1. Settings → Network
  2. Check Enable Network Adapter, Set attached to Bridged Adapter, Select the Name of your network interface which is connected to the same network of other clients (LAN machines).

    bridged network adapter for virtual box

  3. Don't forget to configure (or just disable) Windows Firewall on the guest. If you don't do this, it won't respond to pings, for example.

  4. Also, might need to hit 'Repair' on network connection on the VM (as I had to after following the above).

  • 2
    Oh god, you're right. That's what the issue was. That fixed it. Made this waaay too hard on myself. Thanks! – Someone13 May 3 '14 at 9:43
2

you can do it by File -> Preference -> network -> add host only network

enter image description here

and add 2nd adapter on virtual device settings -> network -> adapter2 click checkbox and select host only adapter enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.