I'm using Ubuntu 14.04 and PlayOnLinux 4.2.2. I managed to get League of Legends almost running perfectly, there are only two problems. The first is that the shop to buy things with IP/RP is just a black screen. Here is a screenshot:

League of Legends - Empty shop

The second problem is that in the game, during the match, some menus are messed up, as if they were in a different resolution from the game's current resolution. For example, the item shop opens a normal window, but this window's contents are all over the screen. Here is a screenshoot:

League of Legends - Broken in-game shop

All the rest is working fine, I even get high FPS. I installed LoL via PlayOnLinux and then I applied TuxLoL patch. I have an Optimus Notebook, Dell Inspiron 14R 5421, it has an Intel integrated video card and Nvidia GeForce 730M dedicated card, which are properly handled by Bumblebee.

How do I fix these two problems? Could somebody help me, please?

  • What version of mono package do you have installed? I've tried with mono-runtime (3.2.8) and I get that pastebin.com/kbwqWmPp Installing mono-devel (3.2.8) packages I get that pastebin.com/ZbA8rQ21 Thanks!
    – user278991
    May 7, 2014 at 11:39
  • Your solution does not seem to fix all the problems as you don't mention anymore the problem of the outgame shop. I don't know if you still have an issue but after following your tuto I remain with a black screen for 5 seconds and then the game shut down just after opening RP/IP shop.
    – ElNikopol
    May 8, 2014 at 16:07
  • @ElNikopol, I mentioned in the end of my answer that user store is working and I even posted 3 print screens showing it's working.
    – renatov
    May 9, 2014 at 2:41
  • See also: github.com/TheUnnamedDude/pol_league_of_legends
    – Jonathan
    Mar 24, 2017 at 21:05
  • I know this question is pretty old but does LoL still work on linux with the recent changes to riot's client? I haven't dug into this but I am very interested in switching completely to linux and am contemplating doing so but might not.
    – cr1pto
    Jul 18, 2021 at 18:32

3 Answers 3


Answer updated: as of September 2015, only steps 1, 2 and 3 are required for a 100% working League of Legends on Ubuntu 14.04

I've finally solved all problems and League of Legends is working 100%. Here is a comprehensive tutorial on HOW TO PLAY LEAGUE OF LEGENDS ON UBUNTU 14.04.

  1. Install your video card driver (in my case, I have a NVIDIA GeForce 730M):

    Open Unity Settings --> Software & Updates --> Additional Drivers and click on the proprietary driver option. Here is a screenshot:

    Software and Updates Dialog

  2. Install PlayOnLinux:

    sudo apt-get install playonlinux
  3. Install League of Legends through PlayOnLinux

    • Open Play On Linux
    • Click "Install"
    • Type "league of legends"
    • Select the game and click "Install" buttom.

    Here is a printscreen:

    PoL install menu

    Just click Next >> Next >> Next* >> Finish*. Make sure you don't change anything, install in the default directory (don't change anything in the installer) and unmark "Launch League of Legends" when the installation is over.

  4. Install TuxLoL (not needed any more, it's here just for reference)

    • Download it from here: https://bitbucket.org/Xargoth/tuxlol/wiki/Home
    • Unzip anywhere you want
    • Enter the folder you just unzipped (where there is the tuxlol.exe file) and execute it:

      $ mono tuxlol.exe patch --dir "LEAGUE_OF_LEGENDS_DIR"

      Obviously, replace LEAGUE_OF_LEGENDS_DIR with your League of Legends directory. In my case, it's installed here:

      ~/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends/

      PS: You'll have to reapply this patch everytime a new LoL update is released.

  5. Prevent in game store big items (not needed any more, it's here just for reference)

    • Navigate to /home/[username]/.PlayOnLinux/wineprefix/[virtualdrivename]/drive_c/Riot Games/League of Legends/RADS/solutions/lol_game_client_sln/releases/[0.0.0.XXX]/deploy/DATA/menu/hud

    • Open the file corresponding to the resolution you play with. For example hud1680x1050.ini

    • Add these lines and save:


    If you don't do this, in game store icons will be too big, here is a print screen:

    mismatched sizes game view

    After adding these lines, your in game store will be just fine:

    correct game view

PS: some people reported they had to install Internet Explorer using PlayOnLinux for the store to work. But for me, it worked just fine.

  1. Play the game!

    To play the game, just open PlayOnLinux, select League of Legends and click "Run". Remember, if you have an Optimus Notebook, you must open PlayOnLinux as mentioned in section 5 every time. Here are some screen-shots of the game running:

As you can see, League of Legends is working 100% on Ubuntu 14.04: user store, in game item shop, Maestro connection and all the maps. Just make sure you follow these instructions to the risk. If I helped you, please upvote.

  • I canceled @Braiam's changes, so the images can be clearer and you all can see better what were the errors and the instructions those images were showing. I accepted all the other editions, thanks!
    – renatov
    May 5, 2014 at 20:16
  • 3
    You should cite your sources (e.g. playonlinux.com/en/topic-11029.html).
    – BenC
    May 9, 2014 at 22:24
  • 4
    @BenC I used about 10 different sources to put all these information together, the one you posted is only one of them. I didn't put links to all of them because some are not totally correct. In my compilation I filtered only the information that worked on Ubuntu 14.04 to produce a 100% working League of Legends.
    – renatov
    May 10, 2014 at 2:06
  • 2
    some details may be missing for people trying to debug their install. There's often long talks with tips on how to debug some issues. This can also be quite useful ;-)
    – BenC
    May 10, 2014 at 10:23
  • 3
    Fixed it, to people like me (newbies to Ubuntu), install the mono-complete package, and then run this command : "mono tuxlol.exe patch --dir ~/.PlayOnLinux/wineprefix/LeagueOfLegends/dosdevices/c:/Riot\ Games/League\ of\ Legends/" the one at the guide doesn't work.
    – Nick Oh
    Jun 18, 2014 at 17:24

enter image description here

Updated 2019

  • Make sure your graphics drivers are up to date and running: nVidia AMD (Intel is automatic) - use nvidia-settings to verify it's running at command line for nvidia

  • Install Lutris

  • Install League

  • After every major League update, UNINSTALL completely & reinstall League again or it may break

Help Video

NOTE: League and graphics drivers run/load better with modern desktop environments such as Budgie on the latest non-LTS Ubuntu

Now to get out of bronze....

  • 1
    I got out of bronze finally guys
    – Jonathan
    Oct 13, 2018 at 22:52

Figured I should post here my solution since it's basically the first thing that popped up on my google search when I ran into this problem, maybe save some other bloke the trouble of digging deeper.

I. The accepted post does not fix the shop, because it does not install Internet Explorer, and the LOL client needs IE in order to generate the shop and whatnot, so basically what you need to do is:

  1. Open PlayOnLinux
  2. Select League of Legends
  3. Go to Configure
  4. Install Components
  5. Install Internet Explorer 8 (make sure you are emulating Win XP for this to work)

II. Making sure you are running Win XP:

  1. Open PlayOnLinux
  2. Select League of Legends
  3. Go to Configure
  4. Wine
  5. Configure Wine
  6. Applications
  7. Windows Version [ Windows XP ]

Also if you go to Libraries here (after you have installed IE8) you should notice it will run the libraries needed for the shop to work.

  • Does work; make sure you install IE8 as described, and not with the standard applications installer (otherwise it ends up on its own virtual drive and is useless) Sep 22, 2014 at 16:20
  • How do I even get to the store? My game seems to crash just before the game starts. I can see the loading bar/numbers, but when the game is about to start, I can heard the ingame noises, but instead of showing me the game, it crashes... Any idea what might be wrong? Nov 14, 2014 at 18:41
  • I didn't have to install Internet Explorer and everything worked just fine. But I put an observation on my answer, saying that some people reported that IE is needed, so if they still have any issues after following those steps, they should install IE to see if it solves. See you in game!
    – renatov
    Apr 29, 2015 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .