2

Sometimes my Unity session crashes just like that - no window decorations, no panel, but whatever was going on in the background continues, like music playback. Problem is though it cannot be restarted, since the option to kill the X server has been removed from 14.04.

I tried to bind the "sudo service lightdm restart" to a shortcut, to no avail. I also tried to restart Unity by typing "unity", "unity --replace", I tried also "compiz --replace" in the TTY session, nothing worked.

My hardware:

System: Kernel: 3.13.0-39-generic x86_64 (64 bit) Desktop: Gnome Distro: Ubuntu 14.04 trusty Machine: System: TOSHIBA (portable) product: Satellite L650 version: PSK1EE-00Y007SK Mobo: TOSHIBA model: Portable PC Bios: INSYDE version: 2.40 date: 11/09/2011 CPU: Dual core Intel Core i3 CPU M 330 (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) Clock Speeds: 1: 933.00 MHz 2: 933.00 MHz 3: 1999.00 MHz 4: 2133.00 MHz Graphics: Card: Intel Core Processor Integrated Graphics Controller X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 10.2.2 Audio: Card: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel Sound: ALSA ver: k3.13.0-39-generic Drives: HDD Total Size: 1500.3GB (35.3% used) 1: id: /dev/sda model: Hitachi_HTS54505 size: 500.1GB 2: USB id: /dev/sdb model: CH11 size: 1000.2GB Partition: ID: / size: 46G used: 9.2G (22%) fs: ext4 ID: /home size: 409G used: 106G (28%) fs: ext4 ID: swap-1 size: 4.09GB used: 0.01GB (0%) fs: swap RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present Sensors: System Temperatures: cpu: 53.0C mobo: N/A Fan Speeds (in rpm): cpu: N/A Info: Processes: 228 Uptime: 11:52 Memory: 1642.5/3753.0MB Client: Shell (bash) inxi: 1.9.17

0

For console use CTRL+ALT+F1 (back to GUI use CTRL+ALT+F7)

Did you use Compiz Config with extra plugins or effects?

If yes, try this: dconf reset -f /org/compiz (this will reset your Compiz settings)

and this: setsid unity (it's creates a session and sets the process group ID)

Compiz Config can mess up, I don't know why, perhaps integrated graphic cards(?) I had those problems too, I remember that only one cure for that kind of problem is reset compiz settings and configure them again with caution.

| improve this answer | |
  • You got that right. I've installed CCSM and enabled additional effects/modified a few things, like the zoom control by mouse, fade in/out window effects and yer, I am using an integrated Intel HD Graphics Chipset 3000. What exactly does dconf reset -f /org/compiz do? – Patrik May 3 '14 at 9:58
  • it will reset your Compiz settings unfortunately – Paul B May 3 '14 at 22:17
  • Thanks a lot, I'll try this should I get that glitch again and post here the results of the above. – Patrik May 4 '14 at 7:31
  • It's not necessary. Later, I'll try to get this glitch on my computer and using strace -Ff -tt -p <PID> 2>&1 | tee strace-log.log I'll try to track that bug. Maybe something will show what is a cause of that glitch – Paul B May 5 '14 at 12:03
  • Thanks a lot Paul. Thing is, when I did what you suggested it reset Compiz but the settings remained, all but the snapping of windows into corners, that got disabled, at least from what I noticed, so it might be related to that. – Patrik May 5 '14 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.