webex is not working in Ubuntu 14.04. Do i need to install 32bit java and fire fox to get this worked? Is there any option in 64 bit itself


7 Answers 7


Finally It resolved for me

Install Oracle Java to solve this issue

Press Ctrl+Alt+T on your keyboard to open a terminal window. When it opens, copy and paste the command below and hit enter. Input your user password when prompts and it will add the PPA repository into your system.

sudo add-apt-repository ppa:webupd8team/java

After that, update package lists via:

sudo apt-get update

To install Oracle Java 8, run:

sudo apt-get install oracle-java8-installer

Change the number 8 to 6 (or 7) in the code to install Java 6 (or 7).

While installation, you’ll be asked to agree the license and then the installer start downloading Java file from oracle website and install it on your system.

To set the default Java, run:

sudo apt-get install oracle-java8-set-default

Also change number 8 to the Java version you want.

  • 1
    This only worked for me with FireFox in 14.04. See Chrome issues in other answers. WebEx is gonna really have to figure out their platform like what GTM did with HTML5. GoTo had some hiccups, but got it right in Chrome IMO.
    – akahunahi
    Nov 4, 2015 at 18:46
  • this only worked in Firefox for me, but the WebEx app has no audio, no video, and has old-school Java look&feel. Basically not usable for anything. (Java v1.8.0)
    – StampyCode
    Feb 2, 2016 at 16:14
  • Webex / Cisco not working and broken on Ubuntu 16.10. I even tried the Chrome plugin, it installs but the webex website keeps giving the error. "Your browser, browser version, or operating system is currently unsupported."
    – Pieter
    Dec 13, 2016 at 7:50

For those who desktop sharing is not working in Ubuntu 14.04 64 bit

  1. Check the existing home directory of webex

    $ ls $HOME/.webex
  2. Lets start from the scratch

    $ rm -r .webex/
  3. Start Firefox again and initiate a meeting

    $ ls $HOME/.webex 
  4. You will be able to start a session, initiate a chat but desktop share may not be working. Then, find the missing libraries:

    ldd $HOME/.webex/1530/*.so >>check.txt
  5. grep the “not found” lines:

    $ grep "not found" check.txt | sort -u
    libgtk-x11-2.0.so.0 => not found
    libgdk-x11-2.0.so.0 => not found
    libXmu.so.6 => not found  ---------------->>>
    libXtst.so.6 => not found
    libjawt.so => not found  ----------->>>
    libXmu.so.6 => not found
    libpangoxft-1.0.so.0 => not found
    libXft.so.2 => not found
    libpangoft2-1.0.so.0 => not found
    libpangox-1.0.so.0 => not found
  6. Install the apt-file program.

    sudo apt-get install apt-file
    apt-file update
  7. search each of the libraries that were not found.

    $ apt-file search libXmu.so.6
    libxmu6: /usr/lib/x86_64-linux-gnu/libXmu.so.6
    libxmu6: /usr/lib/x86_64-linux-gnu/libXmu.so.6.2.0
    libxmu6-dbg: /usr/lib/debug/usr/lib/x86_64-linux-gnu/libXmu.so.6.2.0
  8. Once we knew the libraries, we could use that to install them. Not each of these actually installed packages because some were dependencies.

    sudo apt-get install -y libgtk2.0-0:i386 libxmu6:i386 libgcj14-awt:i386 libpangoxft-1.0-0:i386 libxft2:i386 libpangoft2-1.0-0:i386 libpangox-1.0-0:i386
  9. No need to restart the browser or you machine. Your web-ex will start working.

  • Thanks! But you need to indent the lines of output so they aren't wrapped together in the output. And see Yuv's first answer for a few helpful additional tips.
    – nealmcb
    Dec 29, 2015 at 3:58
  • 1
    This worked great on 16.04. I still got libjawt.so => not found even though I installed openjdk-8-jre-headless:i386 but everything works inside WebEx so I'm happy.
    – galatians
    Jun 22, 2016 at 17:14
  • The missing link! These instructions worked for the most part, I had issue using the output of the apt-file search in step #7 for use in apt-get install for step #8, it said all the libraries I tried were already installed. I ended up just copy/pasting step #8 and installing everything it says to install. POW. Screenshare works now!!! Aug 3, 2016 at 16:00

Assuming that a 64bit system is used (the most common scenario nowadays), there are two approaches to make WebEx work in Ubuntu 14.04LTS:

  1. Make it work "natively"
  2. Use a self-contained manually installed 32bit version of Firefox/Java.

While #1 is preferable because of automatic security updates and less clutter, I only got #2 to work properly. Hence I document both approaches, hoping that somebody will fix my mistake with approach #1.

1. Native Approach (did not work for me)

  • Install Firefox
  • Install JDK
  • Join a WebEx test meeting to create a session inside $HOME/.webex/. It will have a numerical folder name
  • check for unresolved .so dependecies:
ldd $HOME/.webex/????/*.so > $HOME/check.txt
grep "not found" $HOME/check.txt | sort | uniq
  • Find the packages for the missing libraries (apparently you can ignore the missing libjawt.so, it still shows missing after installing libgcj12-awt:i386`)
sudo apt-get install apt-file
sudo apt-file update
apt-file search 
  • Install missing libraries (append :i386 since WebEx is 32bit), for example:
sudo apt-get install -y libasound2:i386
  • When finished, join a test meeting again


  • Audio does not work yet
  • I do not see my counterpart's video

2. Self-contained manually installed 32bit Firefox/Java

Critically Important: You are going to install manually software that is guaranteed to have not yet known vulnerabilities. You will have to keep it up to date yourself.


  • Download the latest 32bit Firefox for Linux
  • Download the latest 32bit Oracle Java for Linux
  • Link the 32bit Java in the Firefox plugins folder
  • Create a script to start 32bit Firefox
  • Create a desktop entry for 32bit Firefox

To do so, open a terminal and enter the following commands. Note that the name of the downloads are correct as of May 13, 2015 and are likely to change very soon.

mkdir webex
cd webex
wget http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/38.0/linux-i686/en-US/firefox-38.0.tar.bz2
wget -O java.tar.gz http://javadl.sun.com/webapps/download/AutoDL?BundleId=106238
tar -C . -zxf java.tar.gz
tar -C . -jxf firefox-38.0.tar.bz2
mkdir firefox/browser/plugins
ln -s ~/webex/jre1.8.0_45/lib/i386/libnpjp2.so ~/webex/firefox/browser/plugins/libnpjp2.so
nano ~/webex/webex.sh
chmod u+x ~/webex/webex.sh
sudo nano /usr/share/applications/webex.desktop 
sudo update-desktop-database

Content of ~/webex/webex.sh. Replace yuv with your username and update the folder name for JAVA_HOME based on the version downloaded/installed

export ENV_HOME_32=~/webex
export JAVA_HOME=$ENV_HOME_32/jre1.8.0_45
export FIREFOX_HOME=$ENV_HOME_32/firefox
firefox --no-remote -P WebEx

Content of /usr/share/applications/webex.desktop. Replace yuv with your username and create some meaningful image in ~/webex/webex.jpg

[Desktop Entry]
Comment=32 Bit firefox for WebEx


  • in XFCE, go to menu Other and start WebEx
  • First Time: Create WebEx profile


  • I was able to join a conference, talk and listen, and see the other webcam
  • I was not able to broadcast my webcam, need to investigate further
  • join a test meeting: http://www.webex.com/test-meeting.html
  • Looks promising but I got the following error after following the instructions of approach 2: ~/webex$ ./webex.sh XPCOMGlueLoad error for file /home/jin1/webex/firefox/libxul.so: libXcomposite.so.1: wrong ELF class: ELFCLASS64 Couldn't load XPCOM.. Any ideas?
    – packetie
    Nov 9, 2015 at 17:40
  • Thank you! The first method worked for me, though you need to feed each result from the "not found" search onto the end of an apt-file search command as eldho's answer shows. And I had similar results as what you got - no audio.
    – nealmcb
    Dec 29, 2015 at 3:56

I had this problem in both Ubuntu 12.04 and 14.04

The issue seems to be a security problem with Java (have a look at this question Cannot start Webex session. Java permission issue?)

The solution on that thread worked for me :)

1) Open Java Web Start 2) On the Security Tab add your Webex server (https://XXXXX.webex.com) to the Exception Site List



Here is the Webex - Linux official support(but even with that not will work properly :-S) * It's a really shame that Cisco Webex still not working properly on Linux.


  • Please consider editing your first paragraph, it is not clear what you're saying.
    – Clayton
    May 23, 2014 at 16:31

I also got this error: Application Blocked. Click for details. The details talked about the domains https://meetings.webex.com and https://akamaicdn.webex.com serving JAR files to me, but not being on my Java "Exception Site List".

I followed the instructions to update my list given at » Java Security Exception Site for WebEx Linux Sagas. To wit:

  • Run the Java ControlPanel: $JAVA_HOME/bin/ControlPanel, which for me is: /usr/lib/jvm/java-8-oracle/bin/ControlPanel
  • Click on the Security tab, and add exceptions as needed.

For me, the issue didn't work until I installed 32 bit Java stuff per the guidance at http://laviefrugale.blogspot.com/2013/10/using-webex-desktop-sharing-on-ubuntu.html

Open a terminal, and run the following commands:

sudo apt-get -y remove icedtea-7-plugin:i386 icedtea-netx:i386
sudo apt-get install openjdk-7-jre:i386 libxmu6:i386 icedtea-7-plugin firefox
sudo update-alternatives --auto mozilla-javaplugin.so

Then, using WebEx in Firefox just worked.

Not the answer you're looking for? Browse other questions tagged .