I just installed Natty from scratch with default options and English UI. I did not change any font settings.

I happen to also read Japanese, it mostly displays fine but the 社 character (meaning "company", a widely-used character) is sometimes displayed using its archaic form, which can not be seen anymore except in temples and old places.

So why use it in Ubuntu? I guess it is a bug with this font? How to fix it?

See below, green-circled is good, red-circled is bad: Natty old kanji


  • Only Firefox and Libre Office seem to display the character properly.
  • This character used to show fine on older Ubuntus, but on the contrary the "直" had the same problem at that time, and it is solved now.
  • Have a look here: wiki.ubuntulinux.jp I can't read a single thing on it but it seems to be the Japanase translation wiki ;)
    – Rinzwind
    May 30 '11 at 8:37
  • Thanks Rinzwind, I am now browsing searching/browsing the wiki pages. May 30 '11 at 10:15

It just looks like your window title font uses an older font. All you need to do is goto System -> Appearance -> Fonts and change your Window Title Font to the same ones as your actual application font.

You may also associate your prettier kanji font as a family of your current windows title font alias in fonts.conf under /etc/fonts/fonts.conf


                <family>Your Japanese Font</family>
                <the rest of previous defined family fonts>

This way font system will default to your preferred Kanji font when the code page is missing in your original font.

By the way, that's not century old character, it's just a font type. It's like saying using Times New Roman is wrong because it's used in Roman times and centuries old. The 社 character can be written with both 示 or ⺭ on the side. All you need to change it is use another font, and that's the way it is in the rest of CJK languages as well.

Same page on my computer, which uses English US as default locale (even though I am Taiwanese). Using the one kind of Kanji font that shows it the way you want: Using the one kind of Kanji font that shows it the way you want

Easily changed to the way you don't want by changing the font for Windows Title: Easily changed to the way you don't want by changing the font for Windows Title

  • This no longer works on Ubuntu 12.04.
    – ish
    Aug 23 '12 at 8:01

Kanji, Simplified Chinese and Traditional Chinese all share a common set of Unicode code points, despite being written differently [edit: not all of the time]. To correctly display Unicode text using these code points, it is necessary to know what language is being used.

This usually either comes from the locale or through explicit tagging of the text, or guessing from the context. I assume you're using an English locale, so only the other two options can be relied on. Presumably the tagging exists in one part of the web page you were viewing and not in the other, leading to the two different glyph choices.

I can't embed HTML demonstrating language tagging on this site, but if you create a web page with the following content and view it in Firefox, you should see the effect:

<p>&#x793e; (no language tagging)</p>
<p lang="ja">&#x793e; (Japanese)</p>
<p lang="zh-CN">&#x793e; (Simplified Chineese)</p>
<p lang="zh-TW">&#x793e; (Traditional Chinese)</p>

In Firefox, you should see both glyphs despite the same code point being used in each paragraph.

  • Thanks! I just tried your webapge: the 4 characters show fine. So I guess it is a different problem? May 30 '11 at 9:46
  • It is quite possible that the language tagging gets lost when setting the window and tab titles in the browser, which could explain the difference. Jun 1 '11 at 8:06
  • I meant: the 4 characters show just like the green-circled character in my screenshot. Jun 1 '11 at 8:22
  • That's weird. On my system I got two using one font and two using the other under Firefox. I've forgotten most of the Japanese I learned, so am pretty hopeless at telling which glyphs should be used with which languages though. Jun 1 '11 at 8:42

[sorry, I‘ve no rights to comment yet.]

1) The “archaic” version, the one with 示 on the left is NOT a modern Chinese variant of that character. Neither in simplified, nor in traditional Chinese. – So, the problem is/was not like the title indicates, that Natty showed a Chinese font/variant/character.

I’m 100% sure for simplified Chinese, but only 98% for traditional (but I checked my dictionaries...).

2) Unicode does NOT use the same codepoints for all “means-the-same” CJK characters. Especially traditional and simplified Chinese use different codepoints, where the characters differ (otherwise not, of course). – This regularly goes so far that Unicode includes additional variants of characters that are half-way between traditional and simplified, but not used anywhere, except under confusion... ;-) (example: 說 说 説).

It is true, that Japanese and Chinese use different variants of some characters, which do not have different codepoints in Unicode.

3) the html-test-snippet from James’ answer is online here. I corrected the Japanese language tag, which should be “ja”, not “jp”. – It shows the same glyph on my computer.

4) I would like to know the name of the offending font. It could even be that it has Japanese origin (but didn’t hit the taste of Nicolas... :-)

  • At backsla.sh/she-test only the first line shows the "archaic" version. Thanks! May 14 '13 at 9:11
  • You mean without tag? Not on my system. – Please, can you check again? I added Vietnamese, Korean, French and English tags. Which of them reveals the “archaic” version as well?? Can you find out what font it is? May 15 '13 at 8:06
  • Ah... and the browser title (the HTML-page has the character in the title as well), which character do you get? – Would be really interesting to know which language your system thinks that is. Seems to be (a nameless?) default configuration for your system. May 15 '13 at 8:09
  • Browser title and lines 1,5,6,7,8 show the red-circled (above) character. Lines 2,3,4 show the green-circled character. Ubuntu 13.04, Firefox 21.0 May 15 '13 at 9:26
  • Interestingly, on the same OS/machine, Chromium shows all "green", while Opera shows only line 5 "red". May 15 '13 at 9:32

Fire up terminal by

Ctrl + Alt + T

Install ttf-vlgothic by

 sudo apt-get install ttf-vlgothic

Logout and log back in if you need.


  • Simple and efficient, that worked even without a logout (Ubuntu 13.04). For non-technical users, installing the ttf-vlgothic package in Ubuntu Software Center should achieve the same. May 14 '13 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.