6

Tried unattended PXE install, it fails at this page

Network autoconfiguration failed
Your network is probably not using the DHCP protocol. Alternatively,
the DHCP server may be slow or some network hardware is not working
properly.

<Continue>

My DHCP server works fine with 12.04 and all other Linux distributions, such as RHEL and SLES. More importantly, pxelinux.0 is fetched over and the kernel and initrd are downloaded and started. So I assume this should be a client problem instead of server's. In particular, the 14.04 installer problem.

Jump to a shell in the installer, found ifconfig is not available. Tried dhclient, it returns no error (return code is 0 too) but still cannot ping the PXE or DHCP servers. The error for failed ping is "Network is unreachable". tcpdump shows there is not any DHCP request on the DHCP server after the initial one in PXE.

lspci shows all the NICs.

01:00.1 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller
...

Any idea what could have gone wrong?

Other info:

ip link shows the interface is p1p1 but /etc/network/interface shows only eth0 is configured.

~ # ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: p1p1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:12 brd ff:ff:ff:ff:ff:ff
3: p2p1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:14 brd ff:ff:ff:ff:ff:ff
4: p3p1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:10 brd ff:ff:ff:ff:ff:ff
5: eth3: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:16 brd ff:ff:ff:ff:ff:ff
6: rename6: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:17 brd ff:ff:ff:ff:ff:ff
7: p2p2: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:11 brd ff:ff:ff:ff:ff:ff
8: p4p1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:13 brd ff:ff:ff:ff:ff:ff
9: p5p1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:22:99:b2:00:15 brd ff:ff:ff:ff:ff:ff

/etc/network # cat interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 172.25.0.101
        netmask 255.255.255.0
        network 172.25.0.0
        broadcast 172.25.0.255
        gateway 172.25.0.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 172.25.0.1
1

The issue seems to be the interface naming issue. To workaround the problem, do the following in the installation shell:

  1. # sed -i 's/eth0/p1p1/' /etc/network/interfaces
  2. # ip addr add [IP address]/24 dev p1p1
  3. # ip link set p1p1 up
  4. # ip route add [IP address]/24 via [GW IP address] dev p1p1

After these steps, go back to the installer through exiting the shell and continue the installation

It looks, if the installation can be instructed to name the interface eth0, then there should not be such a problem.

1

Append biosdevname=0 to the kernel in the PXE default file, that solves this network problem. The reason can be found in this document:

Reference: Nicnaming – Solving it with Biosdevname

0

User277236:
A Few things you may want to consider before doing a "re-installation"

1) Have you updated the system bios to the most recent release?
*- Check with the manufacturer's website if one is available and compare it to the one you currently have installed.

2) Ensure your hardware is properly configured, to permit the installation package to meet the requirements for configuring your network adapter.
*- once again... check the manufacturer's website for any applicable firmware updates.

This 2nd item is probably the single most important "pre-installation" task that gets overlooked. If your hardware, and its supporting firmware is not correctly configured, the installation software will be unable to resolve a possible conflict, resulting in a system halt during the installation process.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.