2

I am the admin of a private server and I'm pretty new to administration. SSH was working fine until I upgraded to 14.04. Something went wrong with the upgrade so I downgraded to 13.04. Now SSH doesn't work, that is, when a remote tries to connect, the server doesn't respond.

  • I used ifconfig to double check the server IP.
  • The network card (wireless) works fine. I can ping 8.8.8.8 without a problem.
  • If I sudo service ssh status I see a process. When I ps -ef | grep sshd I see the process running.
  • Doing a netstat -ln I can see tcp ... 0.0.0.0:22.
  • /etc/ssh/sshd_config shows password auth is enabled.
  • There is a ~/.ssh directory with a 'known_hosts file in it.
  • On the server, I can ssh localhost and get a response.

Anyone know what could be happening? What should I do next?

  • Is SSH the only thing that's not working? Are you sure you're using the right IP address? – Louis Matthijssen May 2 '14 at 17:35
  • 1
    could it be due to keys ? ~/.ssh/ is that folder there? – Jay Aurabind May 2 '14 at 17:36
  • Could it be, after upgrading, that the upgrade process asked you to disable password logins? So you would have to do the according changes in /etc/ssh/sshd_config – mcantsin May 2 '14 at 17:44
  • If I try to run the ssh script in init.d directly, nothing happens. But if I run sudo service ssh status, then I get an output. On my system, it says "ssh start/running, process 22120". – Marty Fried May 2 '14 at 18:18
  • 3
    Is port 22 opened in your firewall? – Oli May 3 '14 at 18:05
1

It was the firewall on the server. The update process must have closed port 22. I used ufw to open it. Thanks to @Oli for the suggestion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.