I'm currently developing an application for Ubuntu Touch. It already has some basic functionalities and utilizes localstorage/SQLite. When running directly from the Ubuntu SDk itworks fine but when I create a click package and install it to my actual device the database doesn't seem to work. I thought it's related to the security groups but I already added almost all of them except the media groups but still no luck.

My device is a Nexus 7 2013 and i install the click package through the following commands since Install to device functionality doesn't work in Ubuntu SDK app.

sudo pkcon install-local filename
sudo click register --user=phablet packagename  version

Finally solved my problem... all I have to do is to make sure the name property of my mainView is the same as the name field in my manifest file.

That's it...thanks for those who considered answering my question :)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.