1

I have a Lenovo Thinkpad T60 running 12.04.4 LTS, Precise Pangolin; the desktop is KDE. Starting today, the display goes blank after 33 seconds of inactivity. Clicking or even moving the mouse, or pressing a key, resets the 33-second timer.

I have checked the following settings:

  • System Settings / Screen Saver Settings (screenshot): These are turned off. Turning them on and setting an explicit timeout of 9 minutes did not change the behavior.
  • System Settings / Energy Saving Settings (screenshot): These are turned off. Turning on "Dim Display and setting to 10 minutes did not change the behavior.
  • X server settings (xset) : The xset q command reported:

    Screen Saver:
      prefer blanking:  yes    allow exposures:  yes
      timeout:  0    cycle:  600
    

    The timeout: 0 indicates that the X screen saver feature is disabled. Explicitly disabling it with xset s off did not change the behavior.

How do I stop this annoying screen blanking?

4 Answers 4

4

The problem was in the DPMS settings. These are settable in two places:

  • Under System Settings / Configure Energy Saving Settings / Screen Energy Saving. (Screenshot). Enabling this and then disabling it again fixed the problem.

  • Under the X server DPMS settings, accessible through xset. The output of xset q included:

    DPMS (Energy Star):
      Standby: 33    Suspend: 49    Off: 66
      DPMS is Enabled
      Monitor is On
    

which explains the 33 seconds. Enabling and disabling “Screen Energy Saving” as described above reset this to:

DPMS (Energy Star):
  Standby: 21600    Suspend: 32400    Off: 43200
  DPMS is Disabled

presumably the command xset -dpms or xset dpms off would have fixed the problem in the same way.

2

While viewing videos on my htpc, the screen would blank after 10 minutes with no keyboard/mouse input. Obviously not desirable behaviour for an htpc. Turning off screensavers and power saving did not have any effect. Eventually, my web searchs led me to believe this was caused by the xserver. I tested this by running the following:

xset s off && xset -dpms

in a terminal at the beginning of a session and confirmed that this did eliminate the undesired screen blanking. Running "xset -q" in the terminal confirms DPMS (Energy Star) was disabled.

In order to avoid having to open a terminal and run this command at the start of each session, I set this to run at system boot. The screen blanking was back and "xset -q" showed DPMS enabled. Further searching revealed this behaviour is initiated at login and overrides the command run at boot. To run this automatically, just add the lines below to the end of the .profile in your Home folder.

# Turn off screen blanking xset s off && xset -dpms

If you don't see .profile, open your Home folder in your file browser, click on 'View' and select 'Show Hidden Files'. Then just right click on .profile, select 'Open with text editor', copy and paste the above on a blank line at the end of the file and save the modified file.

1

My wifi LED was blinking and when I'd fixed it my screen started going black every 10-15 seconds.

I fixed it easily. Open your terminal and type

sudo xset -dpms

Or if that didn't work for you, try

sudo xset -dpms off 
1
  • 3
    Spelling and grammar errors aside, it's not clear what you are saying. Sep 2, 2017 at 15:43
1

If other solutions (using control panel, using the 'xset' command with various options, etc.) do not solve this for you, you might try this:

sudo apt-get remove phoneui-apps phoneuid phonefsod

Explanation:

I tried numerous combinations of xset commands, and every GUI I could find that claimed to relate to screen blanking, but nothing worked - most of the time, the screen would blank after ~33 seconds of inactivity.

It occurred to me that perhaps some wayward daemon was doing this for some reason, so I looked at system logs, and found this in /var/log/auth.log:

Jan  3 15:48:01 my-host-name dbus[886]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=0 pid=1115 comm="/usr/sbin/phonefsod ") interface="org.freesmartphone.Device.Display" member="SetBrightness" error name="(unset)" requested_reply="0" destination="org.freesmartphone.odeviced" (uid=0 pid=959 comm="/usr/sbin/fsodeviced ")
Jan  3 15:48:14 my-host-name dbus[886]: message repeated 2 times: [ [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=0 pid=1115 comm="/usr/sbin/phonefsod ") interface="org.freesmartphone.Device.Display" member="SetBrightness" error name="(unset)" requested_reply="0" destination="org.freesmartphone.odeviced" (uid=0 pid=959 comm="/usr/sbin/fsodeviced ")]
Jan  3 15:48:23 my-host-name dbus[886]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=0 pid=1115 comm="/usr/sbin/phonefsod ") interface="org.freesmartphone.Device.Display" member="SetBrightness" error name="(unset)" requested_reply="0" destination="org.freesmartphone.odeviced" (uid=0 pid=959 comm="/usr/sbin/fsodeviced ")
Jan  3 15:48:31 my-host-name dbus[886]: message repeated 2 times: [ [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=0 pid=1115 comm="/usr/sbin/phonefsod ") interface="org.freesmartphone.Device.Display" member="SetBrightness" error name="(unset)" requested_reply="0" destination="org.freesmartphone.odeviced" (uid=0 pid=959 comm="/usr/sbin/fsodeviced ")]
Jan  3 15:48:41 my-host-name dbus[886]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=0 pid=1115 comm="/usr/sbin/phonefsod ") interface="org.freesmartphone.Device.Display" member="SetBrightness" error name="(unset)" requested_reply="0" destination="org.freesmartphone.odeviced" (uid=0 pid=959 comm="/usr/sbin/fsodeviced ")
Jan  3 15:49:01 my-host-name dbus[886]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.8" (uid=0 pid=1115 comm="/usr/sbin/phonefsod ") interface="org.freesmartphone.Device.Display" member="SetBrightness" error name="(unset)" requested_reply="0" destination="org.freesmartphone.odeviced" (uid=0 pid=959 comm="/usr/sbin/fsodeviced ")

The references to "Device.Display" and "SetBrightness" seemed suspiciously relevant. I don't specifically recall installing these packages, but I was trying to extract data from a semi-functional mobile phone a while back, so I probably did it then. In any case, I knew I didn't need these packages now, so I removed them (see 'apt-get remove' command, above), sat back, and waited for the screen to blank... and waited some more... and it didn't. :-D

Again, I suggest trying the other possible solutions (system settings GUI, xset commands, etc.) first, simply because they apparently solve the problem for some people, and they seem more likely to work. OTOH, unless you happen to be using these packages, removing them is harmless (and if they're not installed, apt-get will just say so and you haven't hurt anything). Hopefully, this will help someone...

Not the answer you're looking for? Browse other questions tagged or ask your own question.