16

I'm running Ubuntu 14.04. I generally have the unity launcher in auto-hide mode. Problem starts if the desktop has been locked and then unlocked. Then the unity launcher does not disappear again.

  • 4
    Try this command in terminal : setsid unity & then try autohide! – Deepen May 2 '14 at 15:47
  • @Jax-L Worked. But starting new session is not a permanent fix. – CosmoRon May 2 '14 at 16:58
  • session problem? what happens? comment – Deepen May 3 '14 at 4:42
  • Press Alt+Ctrl+F3,login with username & password & try this dconf reset -f /org/compiz/ then setsid unity then sudo reboot – Deepen May 3 '14 at 4:58
  • 1
    Interestingly the problem appears to be happening on if I lock the system using Super+L but does not happen if it is locked using Alt+Ctrl+L. – CosmoRon May 3 '14 at 17:55
18

Avoid holding down the Super button.

When locking the screen with Super + L the Super key is normally held down before pressing Super. But holding down Super is in itself a shortcut to get the Shortcut Help Screen up. By using this to lock the computer, you make the sidebar reveal itself before it's "interrupted" by the screen locking. This is the reason why using Alt+Ctrl+L does not produce the same effect: none of those keys have any effect on the sidebar, dash or the Help screen.

Either rapidly tap Super+L simultaneously (DO NOT HOLD DOWN Super), use Alt+Ctrl+L or find a way to remove the Super shortcuts for the Dash/Sidebar.

EDIT: Also found that if your sidebar gets stuck, you can tap Super twice to get rid of it.

  • 3
    So this is a bug right? The workaround you describe does work but it's very annoying :( I looked around but didn't see a bug report. I'll try to file one later. – rimez Jun 25 '14 at 12:41
  • Yeah, I think this is a bug. I couldn't find a bug report for it either. It's a small annoyance with unity, but I don't think is high priority, so I kinda just left it. – Melvin Sowah Jun 26 '14 at 6:50
  • 3
    Bug report is here: bugs.launchpad.net/ubuntu/+source/unity/+bug/1334998 – rimez Jun 27 '14 at 7:44
  • That double tapping Super trick is exactly what I was looking for! Thank you! – flickerfly Jul 31 '14 at 15:16
16

You may have triggered the four-finger multi-touch command for revealing the launcher. Try swiping four fingers to the left.

Source: https://wiki.ubuntu.com/Multitouch

Found completely by accident.

  • Yeah, I was getting real tired of restarting lightdm just to un-hide my launcher. – AManOfScience Sep 15 '16 at 12:44
  • 2
    Double tapping Super didn't do nothing on my ubuntu 16.10 while swiping 4 fingers to the left worked perfectly – arainone Mar 25 '17 at 11:37
3

I solve it by changing the button with CCSM (CompizConfig Settings Manager):

  1. If not already done, install compizconfig-settings-manager with the following command:

    sudo apt-get install compizconfig-settings-manager
    
  2. Open CCSM.

  3. Select "Desktop" -> "Ubuntu Unity Plugin" -> "Launcher"

  4. Turn the "Hide Launcher" from "Never" to "Autohide".

Screenshot

  • Welcome to AskUbuntu! Please refrain from posting links directly in the answer, as they may change, and become dead. Also please explain your answer with more detail. – No Time Feb 15 '15 at 3:25
1

This is considered a fixed bug and is resolved by Unity 7.2.2+14.04.20140714-0ubuntu1. The following command will bring you to the latest version. You may need to log out and back causing unity to restart to see the resolution.

sudo apt-get upgrade unity

Here is the official bug report: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1320438

0

i had this problem ! you have to move mouse cursor to left top and press rightClick mouse + leftclick mouse and drag to center left . hope work it for you ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.