10

I have a Windows 7 with VirtualBox. I did install a fresh downloaded Ubuntu 14.04 (64bit). I did install the guest additions. I wanted to set the screen resolution to a higher value than 640x480. I did go over on/off (top right)--system settings--hardware--viewing devices.

I get only "eingebaute Anzeige" (German, Wnglish would probably be "builtin display") and only one screen resolution. I have found a howto for Ubuntu 9 and did try to edit/create an /etc/X11/xorg.conf. But this too didn't work.

  • 1
    Ubuntu 14.04(guest) running on older VBox have the problem of getting wider screen. You have to update VBox(and also its corresponding guest additions) to the latest version inorder to get Ubuntu 14.04 in wider screen. See this answer. – Avinash Raj May 2 '14 at 13:02
  • See also: Screen Resolution Problem with Ubuntu 14.04 and VirtualBox askubuntu.com/questions/451805/… – se0808 Apr 7 '15 at 19:38
14

Sometimes the packaged version of the Guest additions gives better results.

So I'd suggest to update the Guest additions with the VM package manager. So login first into your VM and open a Terminal to type:

sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11

Finally restart the Ubuntu VM to complete the installation.

You should get access to higher resolutions now.

  • Thanks for the hint. I tried it: sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 but i get the error sudo: unable to change to root gid: Die Operation ist nicht erlaubt - which means in English operation not permitted - sorry, can not input an new line - thanks, Thomas – user277068 May 2 '14 at 14:12
  • Perfect, that worked... – Arvind07 Apr 22 '15 at 3:49
  • @user277068, that's probably a problem with sudo in general rather than this particular command. Try sudo echo hi and see if you have the same problem. – Olathe Jan 2 '16 at 8:09
4

Original screen size was 640 x 480.

In Oracle VM VirtualBox Manager go to:

File --> Preferences

Click on Display

On the Maximum Guest Screen Size dropdown change Automatic to None

Click on OK

On my Dell Precision M6500A laptop system running Windows 7 after restarting Oracle VM VirtualBox Manager and then starting the Ubuntu 14.0.4 VM my default screen settings (1024 x 768) were taken with (800 x 600) as a second choice

1

I had the same problem. What worked for me was upgrading VirtualBox to the latest version, and installing from its built-in Guest Additions CD.

1

You should install the virtual-box guest additions by entering the devices menu and select "install Virtual Box Guest Additions". Then you go to your running session of your virtualized OS and open a terminal. Go to your media path : /media/(user-name)/vbox.... (I don't remember the name of the CD) then in the terminal run the following command

apt-get install gcc (if you don't have it yet)

./VBoxLinuxAdditions.sh (the name of your installation file (it ends by .sh)

if the previous command don't work execute this one :

sh VBoxLinuxAdditions.sh

Let this run and reboot your VBox machine. It should have the correct screen resolution now.

Be sure to have an up to date version of your Virtual Box Software.

0

virtualbox4.2.12 is unusable, please upgrade your virtualbox first. I have tried every method over ubuntu official forum, and the methods doesn't work, after I upgrade my virtualbox to 5.X, and it works.

protected by Community Jan 2 '16 at 10:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.