1
$ rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no

$ lspci | grep Wireless
03:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

$ uname -a
Linux ASUS-X75VC 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Does anyone have any idea what's wrong?

UPD:

$ sudo rfkill block wifi
$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: asus-wlan: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
$ sudo rfkill unblock wifi
$ rfkill list 
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  • Here is the solution. You may just have to adapt the driver name but that should be close. – Adrien Horgnies May 2 '14 at 10:51
  • @AdrienHorgnies have no idea how to adapt it – outoftime Jan 5 '18 at 22:43
1

My problem is fixed by the command:

echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf
| improve this answer | |
  • What does this command do? It would be better to edit your answer and add some explanation on how this command works. – Parto Jun 23 '14 at 8:42
  • ⁺¹, this fixed the problem on Asus x75V. The purpose of the option is to enable Fn+F2 combination (I did use «1» value, like in the answer). What's interesting, however, is that it didn't fix the problem with Fn+F2 for that Asus, but Hard blocked upon boot changed its value to «no», thus getting WiFi problem fixed. – Hi-Angel May 5 '16 at 12:14
0

Hi Acccording to your terminal reply your "phy0: Wireless LAN"'s hard drive is block. if you want to unblock it just press your wireless shortcut key on you keyboard. Example mine is Fn+f2 on my asus laptop. Hope it can solve your problem, And have a nice day.

| improve this answer | |
  • I tried. Doesn't work for me. Perhaps, I should close theme, because it is partly outdated, I have clean 14.04.2 and didn't try to fix WIFI yet. – outoftime Jun 27 '15 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.