It is being observed since my upgradation to Ubuntu 14.04, that the Firefox browser is terribly slow. Can anything be done about it?

  • 1
    sudo spt-get install preload & restart your pc. First time you open after reboot may be a bit slow but with this app it should work better! – Deepen May 2 '14 at 1:52
  • I had the same problem, you could try Aurora (Firefox Nightly), this is much faster for me but it can contain bugs. – Louis Matthijssen May 2 '14 at 5:39
  • Works properly,thank you my friend.. Finaly i think they solve the problem in firefox 32 downloaded yesterday.. Thanks again. – user240480 Sep 3 '14 at 8:28

Well I checked a youtube video, that shows a procedure, and it worked perfect for me!. Now firefox is way faster that before, and more than that, is faster than chromium!. The procedure is basically the following:

  • open a new tab in firefox and write "about:config". Enter.
  • Press in "I'll be carefull, I promise", in order to get into the settings page.
  • Once in the settings page, In the "filter" field write: network.http
  • Go to the list below and double click "network.http.pipelining" in order for it to change from "false" to "true"
  • do the same for "network.http.proxy.pipelining"
  • Now, in the "filter" field write: network.dns
  • Go to the list below and double click "network.dns.disableIPv6" in order for it to change from "false" to "true".

That's all! now you have the Fastest browser you'll ever find!.

Just for the record: Firefox version: 29.0 , Ubuntu version: 14.04

  • I had followed the same section of changes to Firefox, and there's a good link to suggestions at ubuntuforums.org/showthread.php?t=2208740 – Charles Green May 31 '14 at 14:32
  • I can find a "filter" field. Any idea why it would be missing for me? – zkurtz Dec 27 '15 at 21:22
  • 2
    @zkurtz I don't know if you figured it out but by filter field he means the search input at the top of the page. – GoodPie Mar 3 '16 at 6:23
  • it is working...... (y) .. :-) – Parnab Sanyal Nov 12 '16 at 17:28
  • 1
    as of Firefox 54 pipelining support has been removed (no longer useful). – Kevin Feb 14 '19 at 19:38

I found quite a bit of information about this on another source, can't remember where.

In the Add-ons section of the tools, disable all the unity, gnome and ubuntu extensions to firefox. Especially if you use AdBlockPlus (as I do) something in them is interferring with the operation of Firefox.

These extensions cannot be deleted from inside Firefox, merely disabled. If after testing, you decide that you want to permanently remove them, use the Ubuntu Software Center, select Firefox, and click 'More Info'. The extensions are checked there, and unchecking them and applying changes removes them from the system.

  • This worked for me too. – Shashwat Nov 10 '17 at 14:44

The problem dissappears if you start from clean firefox profile. Then you can install adblock and it will work fine with the ubuntu extensions.

It seems the problem is something that remains in the firefox profile after the upgrade from 10.04.

One quick solution is:

  1. Configure firefox sync
  2. Wait for sync to finish
  3. Close firefox and move your .mozilla folder to .mozilla.backup
  4. Launch firefox and configure firefox sync again

Unfortunately firefox sync does not sync certificate's configuration so you have to move that manually.

After that I can use all the extensions I used previously (adblock, noscript, ...) without the slowdown.



sudo apt-get purge xul-ext-webaccounts

my Firefox was fast again. As fast as Chrome :)


This is due to a limitation in Firefox architecture design itself: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/990997

Anything that is CPU intensive in the browser will lag its interface.


Take a look at here.

Modify file /etc/sysctl.conf, open it

sudo -H gedit /etc/sysctl.conf

and edit

net.ipv6.conf.all.accept_ra = 0

Reboot the system.

  • since following the above instructions to Blackhole IPv6 route I've not had any more problems with Firefox slow browsing issues and its now been 5 days... – bmullan Feb 11 '16 at 1:19
  • @Lnux don't do just sudo gedit: askubuntu.com/a/270019/158442 – muru Mar 2 '17 at 11:00
  • @muru I didn't know about that. Thanks. – d a i s y Mar 2 '17 at 11:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.