1

I recently upgraded from 13.10 to 14.04 and, as dozens of other people, I was gifted with the grub_term_highlight_color bug.

I then tried to restore GRUB by booting from a live CD and using boot-repair, but the process fails and generates log files, the last of which can be found here:

http://paste.ubuntu.com/7375835/

The machine is a dual boot desktop (Windows 8 with UEFI). All /dev/sda partitions are listed in that log file, but the repair tool insists in saying that an error occurred with the boot loader (it says it couldn't be found).

Maybe this is about UEFI or something else related to the Windows partitions. The fact is I can't use that computer any more, because neither Ubuntu nor Windows will load (and I'm clueless).

I'm aware of all other related questions on Askubuntu - none of them worked for me. Any help is much appreciated.

  • I have the same problem. FWIW, I noticed that your boot-repair output also says that "-y" is an unrecognized update-grub option... – jrennie Jun 3 '14 at 21:59
1

I had a similar recent experience: upgraded to 14.04, none of the suggested fixes for this issue seemed to work.

I suspect you have stale EFI files in your EFI partition. There is a launchpad bug specific to the EFI situation which I suspect addresses your case. The fix is to update EFI files manually. Here's a walk-through:

  1. Boot to live CD
  2. Open xterm
  3. Use parted to determine your EFI partition: sudo parted -l (substitute for /dev/sda1 in next step)
  4. Mount your EFI partition: sudo mount /dev/sda1 /mnt
  5. Update the Boot EFI file: sudo cp /mnt/EFI/ubuntu/grubx64.efi /mnt/EFI/Boot/bootx64.efi

Also see Upgrading from 13.10 to 14.04 broke Grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.