1

I just installed Ubuntu 14.04 and I am trying to Install VMware Workstation 10.0.2.bundle. I followed the description on (https://help.ubuntu.com/community/VMware/Player).

While trying to install the Linux headers, I got this error message:

Media change: please insert the disc labeled 'Ubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140417)'
in the drive '/media/cdrom/' and press enter

I inserted the USB stick which I installed my Ubuntu from and I am still getting the error message.

I really need to install VMware workstation.

closed as unclear what you're asking by Radu Rădeanu, waltinator, Anwar, mikewhatever, user117103 May 10 '14 at 16:54

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you originally install without an Internet connection? Do you have internet connectivity? It is probably easier, if you have a broadband Internet connection, to do all your software installs and updates via the Internet repositories. Let me go find the specifics and how to enabled network repos, and I will post another comment with some suggestions. – 0xSheepdog May 1 '14 at 23:56
  • 1
    possible duplicate of How can I avoid "please insert CD/DVD" error when updating Ubuntu? – Anwar May 10 '14 at 13:57
7

The issue is fairly simple, you have the CDROM entry in your /etc/apt/sources.list. Just remove/comment out the line, and you will be fine:

sudo sed -i '/cdrom/d' /etc/apt/sources.list
  • Thanks for your answer dearie. I did Just and i was able to clear that error now am stuck after running the " gksudo bash ./Downloads/VMware-Player-3.1.4-385536.i386.bundle " I get this window "Enter your password to perform Administrative task. This application 'bash'./Downloads/WMware 10.0.2.bundle" lets your modify essential parts of your system. – FirmTech May 2 '14 at 0:15
  • i entered my password and it just takes me to terminal and doing nothing. what do i do please? – FirmTech May 2 '14 at 0:16
  • @user276911 sudo apt-get update – Braiam May 2 '14 at 0:17
  • dear all, thanks for your responses so far. i did what Braiam said, got and install the updates but after entering the password, it still did not start the installer file. what do i do next. – FirmTech May 2 '14 at 2:14
  • 1
    WOoooooowwww, i cant believe a space in between the VMware player name .bundle caused me the problem. I simply renamed the file VMWare 10.0.2.bundle by removing all the spaces making it VMWare10.0.2.bundle and it installed correctly following the help from this ubuntu link. help.ubuntu.com/community/VMware/Player – FirmTech May 3 '14 at 10:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.