2

Can anybody help me please how to allow IGMP protocol in UFW? My provider streams TV signal. I have .m3u8 file as channel list. It contains items as udp://@239.1.1.42:11111.

VLC does not open the stream. When I disable the firewall, it does.

Thanks.

0

I am trying to configure a media server in the local net. The server application that I am using is the MediaTomb. It was the single that allowed me to make transcoding of Theora/Vorbis to MP4/mp2.

Then I will configure the ufw according the tips of the MediaTomb's oficial website: "My UPnP player can not see MediaTomb, what is wrong?". Lacks me to know the syntax.

Ref.: Problems allowing outgoing multicast in ufw

You need to know the ports and protocols — TCP and UDP, only? — that the service uses.

0

For IPTV it is needed to allow both UPD and IGMP protocols.

For UFW edit the /etc/ufw/before.rules file:

# allow IGMP
-A INPUT -i eth0 -p igmp -j ACCEPT
# allow UDP - address range for individual channels
-A INPUT -i eth0 -p udp -d 239.1.2.1/5 --dport 11111 -j ACCEPT
0

Enable Multicast:

sudo ifconfig eth0 multicast

And do not forget to reconnect. That's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.