0

I’m using Ubuntu 14.04 and want to copy music to/on my iPhone 3gs. I already installed the actual mobile device, but neither Rhythmbox nor gmusicbrowser show my phone. Only on Gigolo I can see it, and transfer data, but the music I copy is not working on my phone.

On Amarok I get at least this information:

termined mount-point path to /tmp/kde-cafer/amarok/imobiledevice_uuid_882ba1378fe4eb76e98ad6582dcad031c2247664
calling `ifuse "-u" "882ba1378fe4eb76e98ad6582dcad031c2247664" "-ofsname=afc://882ba1378fe4eb76e98ad6582dcad031c2247664" "/tmp/kde-cafer/amarok/imobiledevice_uuid_882ba1378fe4eb76e98ad6582dcad031c2247664"` with timeout of 10s
command failed to start within timeout
Failed to mount iPhone on /tmp/kde-cafer/amarok/imobiledevice_uuid_882ba1378fe4eb76e98ad6582dcad031c2247664

Does anyone have an idea? Thanks

0

Apple saves music files using a proprietary hash. Rhythmbox used to support this but Apple changed the hash a little while ago and I found while I could transfer the music files to my i device - the device would not play them.

I could not find a solution to the re-hashed files.

I had to revert to the abomination that is iTunes.

  • i also tried with banshee, it seems to work at first, music is copying and transfering, but when i look at my phone, there is no datatransfer. do i understand you right, that i have to sync it with i tunes on an other PC/Mac? thanks Dave – user276842 May 2 '14 at 13:16
  • Unfortunately that is what it looks like unless someone can reverse engineer Apple's hash. I think Rythmbox worked up until iPod version 4 or so then the hash changed. – Dave A May 4 '14 at 23:27
0

The way I add music to my iPhone 5 is through EZMP3 EZMP3 Player on the App Store on iTunes I end up dragging the songs I want on the phone from my mp3 directory on the computer, but they get there and play.

0

It's only possible with a VM on Virtualbox or VMware. It's a shame that iTunes only supports Mac and Window$.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.