0

This question already has an answer here:

I am using Ubuntu 14.04 inside Windows. I can't execute files in my Windows NTFS partitions. It gives the following error:

root@ubuntu:/media/rakesh/Data/My Codes/Test# ./a.out 
bash: ./a.out : Permission denied

I have tried solutions in the following threads but it does not work:

marked as duplicate by user68186, Braiam, Radu Rădeanu, Rinzwind, Warren Hill May 2 '14 at 7:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • With the above command, wouldn't you need to sudo? – No Time May 1 '14 at 23:08
  • Did you tried to move the file to a partition that doesn't use NTFS? – Braiam May 2 '14 at 0:00
  • i ran it from inside root....... check the '#' – Rakesh Malik May 2 '14 at 11:51
  • @Braiam yes.... it runs – Rakesh Malik May 2 '14 at 12:01
  • You found the answer, post an answer instead of editing your question – cmak.fr Aug 5 at 5:15
0

This is common with ntfs mounted partitions. You have to mount the partition with executable rights.

Try this article: .exe file permission fail

  • I have tried, this does not work...... – Rakesh Malik May 1 '14 at 21:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.