Sony Vaio VGN-NW240F
Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

$ lspci -vv -s
Subsystem: Foxconn International, Inc. T77H126.00 802.11bgn Wireless Half-size Mini PCIe Card
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at d2500000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k

$ modinfo ath9k
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
license:        Dual BSD/GPL
description:    Support for Atheros 802.11n wireless LAN cards.
author:         Atheros Communications
srcversion:     BAF225EEB618908380B28DA
alias:          platform:qca955x_wmac
alias:          platform:ar934x_wmac
alias:          platform:ar933x_wmac
alias:          platform:ath9k
alias:          pci:v0000168Cd00000036sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000036sv0000185Fsd00003027bc*sc*i*
[alias...]
depends:        ath9k_hw,mac80211,ath9k_common,cfg80211,ath
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo:   sha512
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           blink:Enable LED blink on activity (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int)
parm:           ps_enable:Enable WLAN PowerSave (int)

My network works perfectly well with this computer on windows 7, and with various other computers and devices. I installed Ubuntu 14.04 today, and it works perfectly, except for the wifi.

When I try to connect (wifi icon, name_of_network), a popup asking for the password keeps appearing every minute or so, and it does not connect. The password is correct.

I tried to delete the network from the connection list (wifi icon, edit connections), restart my computer and try again, to no avail.

Ethernet works perfectly.

I have to assume that it is related to Ubuntu, since the wireless card is recognized and can scan the different networks available.

$ rfkill list
0: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

I do not know Ubuntu 14.04 well enough to even try anything.

Any suggestions?

  • I have the same issue with the Belkin n750 Dual band wifi adapter. I used rt3573sta-master driver for 12.04 and install in manually and it work. I will try to install this in 14.04 and see if doing it manually will solve the issue. – user276736 May 1 '14 at 15:14
  • can you check if its channel no 13? sometimes linux drivers fail to connect to that particular channel – Ubuntuser May 3 '14 at 8:22
up vote 10 down vote accepted

So, my issue was fixed. I'm not extremely sure how, but here is what I did:

sudo service network-manager restart

Maybe that will help others who have this problem, if that was the solution of course.

  • 1
    Have you found a way to make this command run at boot so you don't have to run it every time you log in? – answerSeeker Jul 25 '14 at 18:47
  • I only had to run this command once. – William Abma Jul 31 '14 at 11:35
  • I fixed my problem by downgrading the kernel to Ubuntu 13.10's kernel. The new kernel from 14.04 broke my wifi so now it works the way it should. – answerSeeker Jul 31 '14 at 23:19
  • This worked for me on ubuntu 14.04. Problem always appears when I set my notebook to standby mode. – Goot Jun 28 '15 at 10:42
  • A few years later, I had the same problem but it was because the router was configured for wireless N and the (old) laptop only supported G. Changing to mixed mode on the router fixed the issue. The laptop would see the wifi network and attempt to connect, but fail, making it look (wrongly) like a DHCP problem. – Ben McIntyre Aug 1 '17 at 3:38

Please excuse the lack of formality in this answer - just a quick notice to others for the only thing that worked for me after hours of searching and trying different stuff.

I spent ages trying to get something to work - in the end it became obvious that actually the network card itself worked (because it was fine on another OS); that the wifi network worked (because I could sit there on my phone using it just fine); that the password was correct; and that I could connect to the internet through my wired connection.

The problem it turned out for me was that the network card I have is a bit... not that awesome.

First I found out here what my network card was

sudo lshw -class network

(It's a Realtek RTL8821AE 802.11ac PCIe Wireless Network Adaptor, so I used "RTL8821AE" in my searches)

Then I searched for the driver and it took a while but eventually I found this thread which said that there was a new... I'm gonna say driver (?!) ... and followed the instructions. It was only through the github link that I could actually work out where the ... I'm gonna say driver (?!) ... was and downloaded it on my laptop, unzipped it and copied it over on a USB stick. Then I just did the make commands etc. Boom! it worked :)

And I also had to use this command sometimes to clear a cache or whatever:

sudo service network-manager restart

If anyone else is having the same problem as me where you have to run sudo service network-manager restart every time you login for your wifi to work. I have found a permanent fix for my network adapter that the newer release of ubuntu broke. Ignore my previous comments about downgrading the kernel as the main problem was the new wpasupplicant package in 14.04.

My solution involved getting this ppa: deb http://ppa.launchpad.net/mathieu-tl/nm/ubuntu saucy main it has Ubuntu's 13.10 network manager package and wpasupplicant package. I went to synaptic and downgraded only the wpasupplicant package. I never have to run the command sudo service network-manager restart again.

I got the same problem when I was on my home network and switching between a wired and wireless connection. After working fine for a couple of days, the wireless was suddenly no longer working. I could see the wireless network, but when trying to connect it continuously asked for a password.

I fixed it by installing the new driver for my network card and switching my router off and on.

I hope this helps anyone with similar issues!

This is not a solution rather a workaround, you can use nmcli command line interface for the network manager. For example:

nmcli d wifi connect <Your-SSID> password <Your-Password>

Let me know if you are able to connect with this.

I installed "wifi radar" form softwere center Started it left everything as it was and hit save and exited it. Now my wifi works fine hope this works for everyone. PS. Im running kubuntu 14.04

protected by Community Sep 13 at 9:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.