5

I have Asus N550JV with Windows 8 installed. I want to install Ubuntu 14.04 LTS in a dual boot setup. I am not familiar with turning off "fast boot", disabling "secure boot" and enabling "launch CSM". I created three logical paritions (50Gb "/", 16Gb "/swap" and 150Gb "/home").

Later the installation gives this error:

The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked for use as “Reserved BIOS boot area” and should be at least 1 MB in size. Note that this is not the same as a partition mounted on /boot. If you do not go back to the partitioning menu and correct this error, bootloader installation may fail later, although it may still be possible to install the boot loader to a partition.

I searched on the net and found that both who tried to create that partition and those who just skipped are loosing access to one or both the installed OS-es. Many users ended up reinstalling the whole disk from zero.

My partitions screen shot

Three more partitions at last:

  1. /dev/sda5 ntfs 570Gb 1Gb
  2. /dev/sdz6 ntfs 21Gb 14Gb
  3. free space 0Mb

I would like, before applying one of the two choices (create that 1Mb partition or not), to learn how to to avoid loosing OS access?

  • But, the problem is that with CSM disabled I can't boot from the usb... that's why I did that, what can I do then to boot from my usb without turn off the secure boot?? (sorry this' not an answer, I just can't comment.) – cxnv Feb 8 '15 at 1:31
7

Your problem is trying to install Ubuntu in legacy mode, instead of UEFI mode like Windows. Then you will be installing grub-efi, instead of grub-pc, and you will not need a 1M partition flagged with the grub-bios flag (needed bacause gpt partitioned disks do not have the room right after the Master Boot Block to store grub's core.img executable. Secure boot shouold not need to be turned off, unless your machine has specific problems, but if you can boot Windows with it off, it should make no difference either way.

  • 1
    Great @ubfan1. I just re-enabled secure boot and the DVD booted normally and no warning messages (at least not yet :). I don't know why the two tutorials that I followed insisted to disable it. – Onu May 1 '14 at 17:06
  • 1
    Most people don't understand EFI, so there's a lot of bad information out there. Enabling CSM/legacy mode is one of those widespread bad suggestions that's quite common today. – Rod Smith May 1 '14 at 18:27
  • Enjoying my dual boot. Happy that grub was kept. Thanks to Win8, Asus and Ubuntu... and thank you guys for the precious pieces of information (sorry I don't have yet enough permissions to vote-up your comments). – Onu May 1 '14 at 20:31
  • 1
    This would be more helpful if it explained how to install Ubuntu in UEFI mode instead of legacy mode. I've run into the same issue, which I assume means Ubuntu defaulted to a legacy mode install. I'm finding very little useful information out there about this. – Rob Mosher Dec 13 '16 at 1:42

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.