2

I did a fresh install of Xubuntu 14.04. Executables like Opera Mobile Emulator no longer work. I have already tried the solutions from:

No such file or directory for existing executable

How to run 32-bit app in Ubuntu 64-bit?

Though the error message is not showing up, Opera emulator does not fire up. Any help would be great.

Update: The commands already tried are:

dpkg --add-architecture i386

apt-get install ia32-libs - doesn't work, deprecated

apt-get install libsdl1.2debian:i386

apt-get install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386

apt-get install libc6-i386 lib32stdc++6 lib32gcc1 lib32ncurses5 lib32z1

  • Please edit your question and explain a bit more. Show us the command you are running, explain how you installed it, tell us if this is a fresh install of 14.04 or if you have upgraded from an older Ubuntu release. – terdon May 1 '14 at 10:30
2

The same rings true. You need to install what it needs. You can usually find out what it needs by running it in a command line and interpreting the errors and just installing the :i386 versions of those packages.

In this case...

sudo apt-get install libqtgui4:i386 libgl1-mesa-glx:i386

... Should be enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.